Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 235138 - Resume fails on dell latitude d820
Summary: Resume fails on dell latitude d820
Keywords:
Status: CLOSED WORKSFORME
Alias: None
Product: Fedora
Classification: Fedora
Component: hal-info
Version: rawhide
Hardware: All
OS: Linux
medium
medium
Target Milestone: ---
Assignee: David Zeuthen
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2007-04-03 22:08 UTC by Mads Villadsen
Modified: 2013-03-06 03:49 UTC (History)
2 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2007-12-08 14:02:53 UTC


Attachments (Terms of Use)
Adds D820 to fdi fil (deleted)
2007-04-27 22:48 UTC, Mads Villadsen
no flags Details | Diff

Description Mads Villadsen 2007-04-03 22:08:28 UTC
Description of problem:
Choosing suspend from gnome-power-manager only lock the screen. However running
pm-suspend from a terminal correctly suspends the machine. Pressing the power
causes the machine to resume, but it only gets to an unusable tty - not X. It is
not possible to login to the tty nor is it possible to ssh to the machine.

I can press ctrl-alt-delete to get the machine to reboot and as it is shutting
down I see various error messages about killing init and finally it freezes hard
when shutting down the the cpuspeed daemon,

Version-Release number of selected component (if applicable):
kernel-2.6.20-1.3040.fc7
pm-utils-0.99.3-1.fc7
gnome-power-manager-2.18.1-2.fc7

How reproducible:
Always

Steps to Reproduce:
1. run pm-suspend and wait for machine to suspend
2. press the power button to resume
3. wait a short while an watch the machine freeze
  
Actual results:
Freeze

Expected results:
Machine should return to the same state it was in when I ran pm-suspend

Additional info:
This is all on a dell latitude d820 with intel 945 graphics card and intel 3945
wireless network using the iwlwifi driver

Comment 1 Mads Villadsen 2007-04-26 20:27:00 UTC
The problem is still present with kernel 2.6.20-1.3104.fc7,
gnome-power-manager-2.18.2-1.fc7, pm-utils-0.99.3-1.fc7.

It can now correctly suspend from gnome-power-manager but the problems described
previously still occur on resume.

Comment 2 Mads Villadsen 2007-04-27 22:46:55 UTC
After todays upgrade and a tweak to add D820 to the fdi file suspend/resume kind
of works.

Upon resume the network is unavailable (both wired and wireless), and after a
short while it becomes impossible to start up new programs and even swith to a
tty usin Ctrl-Alt-F1.

Versions of the relevant software:
pm-utils-0.99.3-2.fc7
hal-0.5.9-6.fc7
kernel-2.6.21-1.3116.fc7


Comment 3 Mads Villadsen 2007-04-27 22:48:27 UTC
Created attachment 153672 [details]
Adds D820 to fdi fil

Patch to add support for D820 to fdi file.

Comment 4 Richard Hughes 2007-05-24 12:02:21 UTC
Mads, can you send this to the hal mailing list please, as detailed in
http://people.freedesktop.org/~hughsient/quirk/quirk-report.html - thanks!

Comment 5 Mads Villadsen 2007-05-24 12:05:45 UTC
Already done. The mail is probably stuck in the moderation queue.

Comment 6 Till Maas 2007-09-20 00:26:49 UTC
fdi files are part of hal-info, therefore I change this bug component from
pm-utils to hal-info.

Comment 7 Mads Villadsen 2007-12-08 14:02:53 UTC
Works fine now with a fully up to date Fedora 8. Closing.


Note You need to log in before you can comment on or make changes to this bug.