Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 235123 - vgchange -c [ny] do not change target types when necessary
Summary: vgchange -c [ny] do not change target types when necessary
Keywords:
Status: CLOSED DUPLICATE of bug 289331
Alias: None
Product: Red Hat Cluster Suite
Classification: Retired
Component: lvm2-cluster
Version: 4
Hardware: All
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Jonathan Earl Brassow
QA Contact: Cluster QE
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2007-04-03 20:22 UTC by Jonathan Earl Brassow
Modified: 2010-10-21 16:05 UTC (History)
6 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2010-10-21 16:05:08 UTC


Attachments (Terms of Use)
customer created script that ends up creating a bad mirror (deleted)
2007-04-03 20:22 UTC, Jonathan Earl Brassow
no flags Details
Patch to disallow changing cluster attr if there are active mirrors or snapshots (deleted)
2010-05-14 19:46 UTC, Jonathan Earl Brassow
no flags Details | Diff

Description Jonathan Earl Brassow 2007-04-03 20:22:27 UTC
1) create non-clustered vg
2) create mirror
3) change to clustered vg

result: mirror is still single machine.

Comment 1 Jonathan Earl Brassow 2007-04-03 20:22:27 UTC
Created attachment 151618 [details]
customer created script that ends up creating a bad mirror

Comment 4 Jonathan Earl Brassow 2010-05-07 20:36:41 UTC
This may involve deactivating all LVs (or at the very least non-linear/stripe LVs), changing the cluster flag and re-activating the LVs.

Comment 5 Jonathan Earl Brassow 2010-05-14 19:46:23 UTC
Created attachment 414148 [details]
Patch to disallow changing cluster attr if there are active mirrors or snapshots

Comment 6 Milan Broz 2010-10-21 16:05:08 UTC
For RHEL4.9 added patch above, disallow this operation.

*** This bug has been marked as a duplicate of bug 289331 ***


Note You need to log in before you can comment on or make changes to this bug.