Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 235088 - Several minute delay at "Checking dependencies..." installation stage
Summary: Several minute delay at "Checking dependencies..." installation stage
Keywords:
Status: CLOSED DUPLICATE of bug 232904
Alias: None
Product: Fedora
Classification: Fedora
Component: anaconda
Version: rawhide
Hardware: All
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Anaconda Maintenance Team
QA Contact:
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2007-04-03 18:38 UTC by Hezekiah M. Carty
Modified: 2007-11-30 22:12 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2007-04-03 19:35:31 UTC


Attachments (Terms of Use)

Description Hezekiah M. Carty 2007-04-03 18:38:48 UTC
Description of problem:


Version-Release number of selected component (if applicable):
Using F-6.92 install DVD

How reproducible:
Every time

Steps to Reproduce:
1. Go through the installation, accepting the default package list
2. When the "Checking dependencies in packages selected for installation..."
dialog pops up, the system goes to 100% CPU usage and the GUI becomes
unresponsive for several (not sure exactly how long, but approximately 5) minutes.
3. After this wait, the installation works as it should
  
Actual results:
No feedback indicating that this may take a very long time.

Expected results:
Either completing this step more quickly, or some text/other indication that
this stage of the process may take a while.

Additional info:
This is on a 1.7ghz Pentium-M laptop with 512mb of ram.  According to free, the
free ram never went below ~200mb.  While the GUI was unresponsive, I was able to
switch between VTs and enter some basic commands (top, ps, free) on the provided
command line.

Other than selecting a specific partion and installation location for grub
(/dev/sda1 rather than /dev/sda), all other installation options were left at
their defaults.

Comment 1 Will Woods 2007-04-03 19:35:31 UTC
The progress bar doesn't update properly, but dependency solving is working fine.

*** This bug has been marked as a duplicate of 232904 ***

Comment 2 Nicolas Scheibling 2007-04-05 15:29:53 UTC
I have encountered the same problem.
With a custom Desktop+Devel installation (Gnome+Xfce+Some text utils) the
depsolving takes 14minutes.
I can switch to some VT, doing a "top" and seeing anaconda eating between 97%
and 100% CPU, but switching back to the GUI installer display a buggy screen
with one empty white window. 
The display refresh takes 6 minutes to show back the normal installer.
I think this should be fixed because some user can think the installer has frozen.

I was running the installer on a Celeron 2,93Ghz, 512RAM, with a 160go SATA2
HardDrive.
This step takes aproximately less than 1 minute using FC5 and 14 minutes using
Fedora7.

I will not imagine how slow it would be on a 4 years old computer (or more).





Note You need to log in before you can comment on or make changes to this bug.