Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 235080 - cups/hal hotpluggin printer does not work
Summary: cups/hal hotpluggin printer does not work
Keywords:
Status: CLOSED DUPLICATE of bug 424331
Alias: None
Product: Fedora
Classification: Fedora
Component: cups
Version: 6
Hardware: All
OS: Linux
medium
high
Target Milestone: ---
Assignee: Tim Waugh
QA Contact:
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2007-04-03 18:16 UTC by Jussi Eloranta
Modified: 2008-01-16 10:40 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2008-01-16 10:40:03 UTC


Attachments (Terms of Use)

Description Jussi Eloranta 2007-04-03 18:16:34 UTC
Description of problem:

A printer created by HAL stops working if it is turned off / on
(e.g. hotplugging does not work). A reboot is required to get the
printer working again. If I create the printer manually and choose
not use HAL (from the device list), hotplugging works.

Version-Release number of selected component (if applicable):

The latest FC6 with up to date patches from yum.

How reproducible:

At least in my case always.

Steps to Reproduce:
Plug in a new USB printer (in my case Lexmark E234) and let HAL add the printer.
Print a test page - everyting ok at this point. Unplug the printer (or turn
it off) and plug it in again. Try to print - cups gets stuck on this.
Enabling the queue does not help. Rebooting the machine helps. Restarting
cups does not help either.
  
Actual results:

Printing gets stuck.

Expected results:

Printing should obviously work.

Additional info:

Linux XXXX 2.6.20-1.2933.fc6 #1 SMP Mon Mar 19 11:38:26 EDT 2007 i686 i686 i386
GNU/Linux

On Macbook Pro (intel).

Comment 1 Tim Waugh 2007-05-23 09:43:09 UTC
Do you still see this?  If so, what does 'rpm -q hal-cups-utils' say?

Comment 2 David W. Legg 2007-06-08 19:29:33 UTC
My Dad still gets this problem with his FC6 and a USB Epson C46 printer.

'rpm -q hal-cups-utils' gives:-
hal-cups-utils-0.6.9-1.fc6


Comment 3 Tim Waugh 2007-08-09 13:00:31 UTC
What does 'lpstat -s' say?  If you disconnect the printer, remove the queue,
then connect the printer again, do you see the same symptoms?

The indicated version of hal-cups-utils now avoids using the HAL CUPS backend
when it can.

Comment 4 Jussi Eloranta 2008-01-13 02:48:47 UTC
With Fedora 8 (up to date with yum) plugging in a new USB printer does not work.
I have the following version of hal/cups package: hal-cups-utils-0.6.13-2.fc8.

When I go to (graphical) printer configuration, I can see that HAL added the
following device for the printer:

hp:/usb/Deskjet_5400_series?serial=TH6321522R04K8

Printing test page (or anything else) fails. 

If I change the device URI to:

usb://HP/Deskjet%205400%20series?serial=TH6321522R04K8

the printer starts working immediately. (This was one of the choices in change
device list)

So %20 (hex?) is ascii for space and HAL used underscore _ there. That's the
only difference I can see...

I haven't tried rebooting and seeing if everything still work.



Comment 5 Jussi Eloranta 2008-01-13 02:50:09 UTC
oh - and of course - hp -> usb



Comment 6 Jussi Eloranta 2008-01-13 02:52:23 UTC
Just checked. Not an issue with space & underscore.


Comment 7 Tim Waugh 2008-01-14 11:24:11 UTC
What does 'rpm -q udev' say?  If you have 116, try the test update:
  https://bugzilla.redhat.com/show_bug.cgi?id=424331#c41

Comment 8 Jussi Eloranta 2008-01-16 02:55:43 UTC
Yes, this solved my problem. Thanks!


Comment 9 Tim Waugh 2008-01-16 10:40:03 UTC

*** This bug has been marked as a duplicate of 424331 ***


Note You need to log in before you can comment on or make changes to this bug.