Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 235064 - system-config-date doesn't close when I click okay
Summary: system-config-date doesn't close when I click okay
Keywords:
Status: CLOSED RAWHIDE
Alias: None
Product: Fedora
Classification: Fedora
Component: system-config-date
Version: rawhide
Hardware: All
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Nils Philippsen
QA Contact:
URL:
Whiteboard:
: 235366 (view as bug list)
Depends On:
Blocks: FC7Target
TreeView+ depends on / blocked
 
Reported: 2007-04-03 17:12 UTC by Ray Strode [halfline]
Modified: 2007-11-30 22:12 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2007-04-05 15:32:12 UTC


Attachments (Terms of Use)

Description Ray Strode [halfline] 2007-04-03 17:12:53 UTC
When I try to adjust the timezone in system-config-date and click [OK], it just
pops up an NTP dialog and then goes back to the dialog.  If I disable NTP,
clicking the [OK] button does nothing.

If I close the window with the [X] window manager button then my changes get
dropped, so there is no way right now to change my timezone using
system-config-date.

Comment 1 Ray Strode [halfline] 2007-04-03 19:48:03 UTC
I ran it again from a terminal and got this output when I clicked [OK]:

Traceback (most recent call last):
  File "/usr/share/system-config-date/scdMainWindow.py", line 78, in ok_clicked
    self.apply ()
  File "/usr/share/system-config-date/scdMainWindow.py", line 191, in apply
    self.timezoneBackend.writeConfig(timezone, utc, arc)
  File "/usr/share/system-config-date/timezoneBackend.py", line 52, in
writeConfig
    shutil.copyfile(fromFile, "/etc/localtime")
  File "/usr/lib/python2.5/shutil.py", line 46, in copyfile
    fsrc = open(src, 'rb')
IOError: [Errno 2] No such file or directory: '/usr/share/zoneinfo/America/New
York'

creating a symlink from New_York in that directory to a New\ York made
everything start working.

Comment 2 Nils Philippsen 2007-04-05 14:55:47 UTC
*** Bug 235366 has been marked as a duplicate of this bug. ***

Comment 3 Nils Philippsen 2007-04-05 15:32:12 UTC
should be fixed in system-config-date-1.8.94


Note You need to log in before you can comment on or make changes to this bug.