Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 235017 - PATCH: fix dbus-python from causing abort when the connection is closed
Summary: PATCH: fix dbus-python from causing abort when the connection is closed
Keywords:
Status: CLOSED RAWHIDE
Alias: None
Product: Fedora
Classification: Fedora
Component: dbus-python
Version: rawhide
Hardware: All
OS: Linux
medium
medium
Target Milestone: ---
Assignee: David Zeuthen
QA Contact:
URL:
Whiteboard:
Depends On:
Blocks: FC7Target
TreeView+ depends on / blocked
 
Reported: 2007-04-03 11:52 UTC by Hans de Goede
Modified: 2013-03-06 03:49 UTC (History)
1 user (show)

Fixed In Version: 0.80.2-3
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2007-04-04 02:57:32 UTC


Attachments (Terms of Use)

Description Hans de Goede 2007-04-03 11:52:02 UTC
Matthias Saou from freshrpms has requested me to look into a crash on x86_64 he
encountered while packaging elisa, for the elise packages see:
http://ftp.es6.freshrpms.net/tmp/extras/

This crash is caused by dbus-python checking the validity of the args passed to
the close method, while that method has no args (null pointer). Upstream has
already fixed this with this git commit:
http://gitweb.freedesktop.org/?p=dbus/dbus-python.git;a=commitdiff_plain;h=8dce2df1ceacffb2aa6e2cc8b1d4b58ee95ac5b1;hp=4f88700588d80861c8520e56407d3a40d5bd86e6

Can you please build a new version with this patch?

Comment 1 David Zeuthen 2007-04-04 02:57:32 UTC
* Tue Apr 03 2007 David Zeuthen <davidz@redhat.com> - 0.80.2-3
- Rebuild

* Tue Apr 03 2007 David Zeuthen <davidz@redhat.com> - 0.80.2-2
- Don't examine args for functions declared METH_NOARGS (#235017)



Note You need to log in before you can comment on or make changes to this bug.