Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 235012 - PATCH: fix python-daap segfaults on x86_64
Summary: PATCH: fix python-daap segfaults on x86_64
Keywords:
Status: CLOSED NEXTRELEASE
Alias: None
Product: Fedora
Classification: Fedora
Component: python-daap
Version: rawhide
Hardware: All
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Jeffrey C. Ollie
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2007-04-03 10:45 UTC by Hans de Goede
Modified: 2007-11-30 22:12 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2007-04-03 12:36:45 UTC


Attachments (Terms of Use)
PATCH fixing 64 bit segfault / stacksmash abort (deleted)
2007-04-03 10:45 UTC, Hans de Goede
no flags Details | Diff

Description Hans de Goede 2007-04-03 10:45:09 UTC
Matthias Saou from freshrpms has requested me to look into a crash on x86_64 he
encountered while packaging elisa, for the elise packages see:
http://ftp.es6.freshrpms.net/tmp/extras/

This crash is caused by an error in md5.h in python-daap where a long is used as
a 32 bit var, there is a "#ifdef __alpha" in there to work properly on alpha,
this could be changed to "#if defined __alpha || defined __x86_64__ || defined
__ppc64__ || defined __ia64__" (with others to follow in the future) but I've
choosen to instead make the code arch indepenent. The attached patch does this. 

Please build a new version with this patch, and send the patch upstream.

Comment 1 Hans de Goede 2007-04-03 10:45:09 UTC
Created attachment 151550 [details]
PATCH fixing 64 bit segfault / stacksmash abort

Comment 2 Matthias Saou 2007-04-03 10:53:31 UTC
Thanks a lot Hans!

Comment 3 Jeffrey C. Ollie 2007-04-03 12:36:45 UTC
Patch applied and new versions built.

Comment 4 Jeffrey C. Ollie 2007-04-03 12:44:06 UTC
It looks like the upstream author has applied the patch to his Subversion
repository.  See:

https://jerakeen.org/svn/tomi/Projects/PythonDaap/CHANGELOG


Note You need to log in before you can comment on or make changes to this bug.