Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 234919 - scp lower/uppercase problem
Summary: scp lower/uppercase problem
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: Fedora
Classification: Fedora
Component: filesystem
Version: 5
Hardware: All
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Phil Knirsch
QA Contact:
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2007-04-02 20:33 UTC by Tony Chamberlain
Modified: 2015-03-05 01:18 UTC (History)
1 user (show)

Fixed In Version: 5
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2007-04-16 13:48:49 UTC


Attachments (Terms of Use)

Description Tony Chamberlain 2007-04-02 20:33:20 UTC
Description of problem:

There are several directories under /home/dir (name changed to protect
confidentiality).  The directories are like "CORE", "CDMA", etc.

we perfomed (from /home) an
   scp -r directory 192.168.5.13:/home/bkup/

then on the 192.168.5.13 machine instead of being upper case CORE, CDMA, etc.,
they were lower case (cdma, core, etc).

an attempt to move them (mv cdma CDMA) gave the message that you could not
move a directory to a subdirectory of itself.  Indeed if I did

ls core  or  ls CORE

they both showed the same (the contents of the directory) so somehow,
directory names became case insensitive.

The file names under these directories did not change though.

Version-Release number of selected component (if applicable):


How reproducible:

do the following (have two machines connected through ip.  In this
example I will use 10.0.0.1 and 10.0.0.2)/.  On the 10.0.0.1 have a directory
with a name in upper case (e.g. /home/TEST).


Steps to Reproduce:
1. from 10.0.0.1 under /home do an  scp -r  TEST root@10.0.0.2:
2. on 10.0.0.2 the directory may be test instead of TEST but both will work.
3. substitute anything you want for root@ as long as it is on 10.0.0.2.  We diod
root to root.
  
Actual results:
direcotry switched to lower case

Expected results:
should have stayed upper case

Additional info:

Comment 1 Will Woods 2007-04-02 21:28:33 UTC
What OS and openssh version is running on each machine?

What filesystems are they writing to?

This works fine for me in FC6/F7.

Comment 2 Tony Chamberlain 2007-04-03 12:46:06 UTC
I forwarded the message to Jan because I don't have access to his machine.
Here is the "from" machine though:

 Linux  2.6.17-1.2141_FC4smp #1 SMP Fri Jun 30 15:08:52 EDT 2006 i686 i686 i386
GNU/Linux

by the way, "cheating" from this machine to itself via scp worked.  So it must
be the machine in Jan's office
that is the problem.

(I took the machine name out because I don't know if it is proprietary or not.
The ip address is 192.168.5.11)

Comment 3 Tony Chamberlain 2007-04-04 16:23:22 UTC
Fedora 6 was isntalled on the machine yesterday so it is no longer possible
to test this the same way.  It works OK with Fedora 6.  Perhaps this should be 
moved to DEFERRED or something?

Comment 4 Phil Knirsch 2007-04-16 13:22:15 UTC
If it works on Fedora 6 and Fedora 7 i'd rather suggest closing it as works in
current release?

Opinions?

Read ya, Phil

Comment 5 Tony Chamberlain 2007-04-16 13:48:49 UTC
Yeah I guess so.
First I thought it was because it was going between
Linux and Windows, but then I realized it was not going
between Linux and Windows.  It was Linux - Linux.

I suppose I can/should close it?

Tony

Comment 6 Phil Knirsch 2007-04-16 14:57:32 UTC
Sure, sounds good to me.

Thanks,

Read ya, Phil


Note You need to log in before you can comment on or make changes to this bug.