Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 234912 - OOo causes X to stall for minutes
Summary: OOo causes X to stall for minutes
Keywords:
Status: CLOSED DUPLICATE
Alias: None
Product: Red Hat Enterprise Linux 5
Classification: Red Hat
Component: openoffice.org
Version: 5.0
Hardware: All
OS: Linux
medium
medium
Target Milestone: ---
: ---
Assignee: Caolan McNamara
QA Contact:
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2007-04-02 19:58 UTC by Rik van Riel
Modified: 2007-11-30 22:07 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2007-04-02 20:20:43 UTC


Attachments (Terms of Use)

Description Rik van Riel 2007-04-02 19:58:19 UTC
Description of problem:

sometimes, when first opening the dropdown menu in OOo, X will stall for 10-15
minutes.  During that time, no other applications, not even the clock applet,
can update anything on the screen.

Version-Release number of selected component (if applicable):

openoffice.org-core-2.0.4-5.3

Steps to Reproduce:
1. start openoffice, in this case I started it from thunderbird with an attachment
2 [details]. edit the document
3. try to open the "File" menu to "save as" the document
4. wait 10-15 minutes for X to return to the land of the living
5. see the clock catch up, xchat reconnect, ...
6. save the document :)
  
Expected results:

Even if OOo is slow opening its menu, it should not prevent the other
applications from showing anything on the screen.   It should also not prevent
the mouse from being able to focus on other windows.

Maybe OOo should not do a grab of the pointer (or server?) until after it has
all the data needed to render the menu?

Additional info:

Comment 1 Caolan McNamara 2007-04-02 20:18:00 UTC
openoffice.org-2.0.4-5.4.17 was the one shipped with for RHEL-5 not
openoffice.org-core-2.0.4-5.3. Is that really the version you have ?

caolanm->ajackson: I *think* I recall some problem in X in the past which
sounded like this ?



Comment 2 Caolan McNamara 2007-04-02 20:20:43 UTC
Ah, there it is.

*** This bug has been marked as a duplicate of 210750 ***


Note You need to log in before you can comment on or make changes to this bug.