Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 234889 - [LSPP] querying cups jobs with sysadm_r does not override mls restrictions
Summary: [LSPP] querying cups jobs with sysadm_r does not override mls restrictions
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Enterprise Linux 5
Classification: Red Hat
Component: selinux-policy
Version: 5.0
Hardware: All
OS: Linux
medium
medium
Target Milestone: ---
: ---
Assignee: Daniel Walsh
QA Contact:
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2007-04-02 19:00 UTC by Klaus Heinrich Kiwi
Modified: 2018-10-19 22:40 UTC (History)
4 users (show)

Fixed In Version: RHBA-2007-0544
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2007-11-07 16:38:49 UTC


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2007:0544 normal SHIPPED_LIVE selinux-policy bug fix update 2007-11-08 14:16:49 UTC

Description Klaus Heinrich Kiwi 2007-04-02 19:00:56 UTC
Description of problem:
When querying jobs with sysadm_r role using lpq or lpstat, cups is not
overriding mls (sysadm_t has mlsfileread attribute)

Version-Release number of selected component (if applicable):
cups-1.2.4-11.8.el5

How reproducible:
every time

Steps to Reproduce:
1. Log-in as any SystemHigh-SystemHigh user
2. Print/enqueue a job
3. Log in as sysadm_r/SystemLow(-SystemHigh) user
4. query jobs using lpq -al $job# or lpstat -W all $InstanceName
  
Actual results:
even root/sysadm_r/sysadm_t can't see jobs above it's clearance

Expected results:
sysadm_r should be able to see jobs above it's clearance, because of mlsfileread
 policy attribute

Additional info:
Is this actually stricter than LSPP? I'm ok with it given that LSPP/RBAC also
are. Either way this needs to be fixed or documented.

Comment 1 Daniel Walsh 2007-04-02 21:14:59 UTC
fixes in selinux-policy-2.4.6-50

Comment 3 RHEL Product and Program Management 2007-04-03 00:11:05 UTC
This request was evaluated by Red Hat Product Management for inclusion in a Red
Hat Enterprise Linux maintenance release.  Product Management has requested
further review of this request by Red Hat Engineering, for potential
inclusion in a Red Hat Enterprise Linux Update release for currently deployed
products.  This request is not yet committed for inclusion in an Update
release.

Comment 5 Klaus Heinrich Kiwi 2007-07-31 20:08:49 UTC
verified fix against selinux-policy-mls-2.4.6-67.el5 and cups-1.2.4-11.8.el5

please close the bug

Comment 8 errata-xmlrpc 2007-11-07 16:38:49 UTC
An advisory has been issued which should help the problem
described in this bug report. This report is therefore being
closed with a resolution of ERRATA. For more information
on the solution and/or where to find the updated files,
please follow the link below. You may reopen this bug report
if the solution does not work for you.

http://rhn.redhat.com/errata/RHBA-2007-0544.html



Note You need to log in before you can comment on or make changes to this bug.