Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 234874 - fslint doesn't use busy cursor during long operations
Summary: fslint doesn't use busy cursor during long operations
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: fslint
Version: 6
Hardware: All
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Pádraig Brady
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2007-04-02 17:49 UTC by Bernard Johnson
Modified: 2007-11-30 22:12 UTC (History)
0 users

Fixed In Version: 2.22-1.fc7
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2007-06-29 14:03:47 UTC


Attachments (Terms of Use)

Description Bernard Johnson 2007-04-02 17:49:40 UTC
Description of problem:
fslint doesn't use busy cursor during long operations

Version-Release number of selected component (if applicable):
fslint-2.20-1.fc6

How reproducible:
Always

Comment 1 Pádraig Brady 2007-04-03 09:16:06 UTC
Hmm. For and against for that.
I didn't do that because one can click the stop button while processing.
To me, a "busy" cursor means the GUI is not currently responsive to input.
What do you think?

Comment 2 Bernard Johnson 2007-04-03 16:23:54 UTC
Well, if it's only accepting cancel button, it wouldn't be considered
"responsive to input".

For example, in the gnome HIG, you have busy cursors and busy interactive
cursors.  Perhaps you'd like to do something similar.

http://developer.gnome.org/projects/gup/hig/2.0/feedback-types.html

The point is that the user gets some visual feedback that an operation is
ongoing and that parts of the gui may not be available.

Comment 3 Pádraig Brady 2007-04-03 16:39:01 UTC
Ok I'm convinced. Sorry I didn't mean to close the
bug previously. I'll fix that for the next version.

Comment 4 Pádraig Brady 2007-05-28 15:51:56 UTC
That was quite tricky actually.
FYI, I documented my trials and tribulations here:
http://www.pixelbeat.org/programming/x_cursors/

Comment 5 Fedora Update System 2007-06-29 14:03:42 UTC
fslint-2.22-1.fc7 has been pushed to the Fedora 7 stable repository.  If problems still persist, please make note of it in this bug report.


Note You need to log in before you can comment on or make changes to this bug.