Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 234837 - krb5-auth-dialog not renewing ticket
Summary: krb5-auth-dialog not renewing ticket
Keywords:
Status: CLOSED DUPLICATE of bug 187485
Alias: None
Product: Red Hat Enterprise Linux 5
Classification: Red Hat
Component: krb5-auth-dialog
Version: 5.0
Hardware: All
OS: Linux
medium
medium
Target Milestone: ---
: ---
Assignee: Christopher Aillon
QA Contact:
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2007-04-02 14:36 UTC by Frederic Medery
Modified: 2009-02-11 20:00 UTC (History)
5 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2009-02-11 20:00:58 UTC
Target Upstream Version:


Attachments (Terms of Use)

Description Frederic Medery 2007-04-02 14:36:32 UTC
Description of problem:
After entering my password in the krb5-auth-dialog, I did a klist and the ticket
is not renewed. I had to use kinit to renew the krb5 ticket

Version-Release number of selected component (if applicable):
krb5-auth-dialog-0.7-1


How reproducible:


Steps to Reproduce:
1.
2.
3.
  
Actual results:
ticket not renewed

Expected results:
krb5 ticket renew (just like a kinit -R)

Additional info:
In RHEL4 the screensaver password renewed the ticket It is not the case with RHEL5.

Comment 1 Petter Urkedal 2007-04-30 07:44:11 UTC
I think the problem may be with the dates of the renewal.  Today, may ticket
cache contained a ticket for Friday.  On first renewal attempt, I got a ticket
for Saturday, which is two days ago.  After kdestroy and a new attept I got a
ticket which would be valid only if I could re-live yesterday backwards:

    Ticket cache: FILE:/tmp/krb5cc_XX
    Default principal: XX@XX

    Valid starting     Expires            Service principal
    04/30/07 09:16:56  04/29/07 09:50:04  krbtgt/XX@XX


    Kerberos 4 ticket cache: /tmp/tktXX
    klist: You have no tickets cached

I decided not to try that, so I used kinit instead, but I'm looking forward to a
more realistic auth dialog.


Comment 2 J. Bruce Fields 2008-09-02 15:06:12 UTC
This is clearly a duplicate of #187485.  (It may just be my lack of bugzilla skills, but I don't see the right way to mark this as a duplicate.)

Comment 3 Patrick C. F. Ernzer 2009-02-11 20:00:58 UTC

*** This bug has been marked as a duplicate of bug 187485 ***


Note You need to log in before you can comment on or make changes to this bug.