Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 234836 - Can't register openoffice.org java components
Summary: Can't register openoffice.org java components
Keywords:
Status: CLOSED RAWHIDE
Alias: None
Product: Fedora
Classification: Fedora
Component: gcc
Version: rawhide
Hardware: All
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Jakub Jelinek
QA Contact:
URL:
Whiteboard:
Depends On:
Blocks: FC7Blocker
TreeView+ depends on / blocked
 
Reported: 2007-04-02 14:24 UTC by Caolan McNamara
Modified: 2007-11-30 22:12 UTC (History)
1 user (show)

Fixed In Version: 4.1.2-8
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2007-04-04 15:59:00 UTC


Attachments (Terms of Use)
patch to make work (deleted)
2007-04-02 14:27 UTC, Caolan McNamara
no flags Details | Diff

Description Caolan McNamara 2007-04-02 14:24:28 UTC
Description of problem:
I have been unable to get gcj to pass the "testtools" test case or afterwards
register java components for OOO since gcc 4.1.2-2

Version-Release number of selected component (if applicable):
gcc 4.1.2-7

How reproducible:
100%

Steps to Reproduce:
build OOo as far as testtools :-)

So, looking at the diff and then doing a bit of googling on the results happily
threw up http://www.nabble.com/Proxies%2C-again-p9765675.html and the patch
there, attached here with the missing bit makes OOo pass testtools again and
register the java components

Comment 1 Caolan McNamara 2007-04-02 14:27:14 UTC
Created attachment 151428 [details]
patch to make work

Comment 2 Jakub Jelinek 2007-04-04 15:59:00 UTC
That patch is in gcc-4.1.2-8.


Note You need to log in before you can comment on or make changes to this bug.