Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 234834 - anaconda is unable to upgrade system, installed on hda
Summary: anaconda is unable to upgrade system, installed on hda
Keywords:
Status: CLOSED DUPLICATE of bug 229704
Alias: None
Product: Fedora
Classification: Fedora
Component: anaconda
Version: rawhide
Hardware: All
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Chris Lumens
QA Contact:
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2007-04-02 14:17 UTC by Leonid Kanter
Modified: 2007-11-30 22:12 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2007-04-11 20:53:07 UTC


Attachments (Terms of Use)

Description Leonid Kanter 2007-04-02 14:17:15 UTC
Description of problem:

I tried to update FC4 system, installed on /dev/hda. Since there are no hd*
devices in FC7, I got message "unable to mount /dev/hda4" and installer ended
with error.

Version-Release number of selected component (if applicable):

6.92 installer

How reproducible:

always

Steps to Reproduce:
1. install FC4 on /dev/hda
2. boot f7 6.92 and try to upgrade FC4

  
Actual results:

It will fail with error message "unable to mount /dev/hdaX"

Expected results:

Upgrade should work

Comment 1 Jeremy Katz 2007-04-02 17:22:38 UTC
What are the contents of /etc/fstab?

Comment 2 Leonid Kanter 2007-04-05 08:26:40 UTC
# This file is edited by fstab-sync - see 'man fstab-sync' for details
# /etc/fstab: static file system information.
#
# <file system> <mount point> <type> <options>                  <dump> <pass>
/dev/hda5       none    swap    sw      0       0
/dev/hda2       /       ext3    defaults,errors=remount-ro      0       1
/dev/hda7       /home   ext3    defaults,errors=remount-ro      0       1
proc    /proc   proc    defaults        0       0
none    /dev/shm        tmpfs   defaults        0       0
none    /dev/pts        devpts  gid=5,mode=620  0       0

/dev/fd0                /media/floppy           auto    pamconsole,exec,noauto,c
odepage=866,iocharset=utf8,managed 0 0
/dev/hdc                /media/dvdrecorder      auto    pamconsole,exec,noauto,i
ocharset=utf8,managed 0 0

Comment 3 Matthew Miller 2007-04-10 16:36:25 UTC
Fedora 7 test bugs should be filed against "devel", not against test1/2/3. This
isn't obvious, I know. Moving this report so it isn't lost.

This is a bulk message -- I apologize if this was actually meant to be targeted
against a different release. If so, please fix or let me know. Thanks.

Comment 4 Chris Lumens 2007-04-11 20:53:07 UTC

*** This bug has been marked as a duplicate of 229704 ***


Note You need to log in before you can comment on or make changes to this bug.