Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 234817 - file reports wrong filetype for microsoft word file
Summary: file reports wrong filetype for microsoft word file
Keywords:
Status: CLOSED RAWHIDE
Alias: None
Product: Fedora
Classification: Fedora
Component: file
Version: 6
Hardware: All
OS: Linux
medium
high
Target Milestone: ---
Assignee: Martin Bacovsky
QA Contact:
URL:
Whiteboard:
: 249582 (view as bug list)
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2007-04-02 10:02 UTC by Ditesh Kumar
Modified: 2007-11-30 22:12 UTC (History)
3 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2007-08-20 13:57:39 UTC


Attachments (Terms of Use)
Example of file that gives false positive (deleted)
2007-04-02 10:02 UTC, Ditesh Kumar
no flags Details

Description Ditesh Kumar 2007-04-02 10:02:08 UTC
Description of problem:

file reports wrong filetype for attached Microsoft Word file. This is due to a
false positive in /usr/share/file/magic on line 9173.


Version-Release number of selected component (if applicable):

4.19-2


How reproducible:

It can be reproduced as follows


Steps to Reproduce:
1. Save attached file to disk.
2. run 'file sealedbid.doc'
3. output should be 'Microsoft Office Document' and not 'Microsoft Installer'
  
Actual results:

Output is 'Microsoft Installer'

Expected results:

Output is 'Microsoft Office Document'

Additional info:

Comment 1 Ditesh Kumar 2007-04-02 10:02:09 UTC
Created attachment 151412 [details]
Example of file that gives false positive

Comment 2 Adam Huffman 2007-06-22 11:21:22 UTC
I have seen this too.

Comment 3 Paul W. Frields 2007-07-25 20:02:05 UTC
See page 8 of the OpenOffice.org Compound Document file format analysis, at
http://sc.openoffice.org/compdocfileformat.pdf -- compare this to line 9464-9465
of the current /usr/share/magic from the file-4.21-1.fc7 package.  Only the
first 8 bytes should be used as an identifier, the rest can vary.  Lines 9464
and 9465 should be reversed for a proper identification.



Comment 4 Martin Bacovsky 2007-08-20 13:27:22 UTC
*** Bug 249582 has been marked as a duplicate of this bug. ***

Comment 5 Martin Bacovsky 2007-08-20 13:57:39 UTC
Thanks to Paul for usefull link. This issue should be fixed in RAWHIDE.


Note You need to log in before you can comment on or make changes to this bug.