Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 234813 - libsane-hpaio problems with OOo
Summary: libsane-hpaio problems with OOo
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: hplip
Version: 6
Hardware: All
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Tim Waugh
QA Contact:
URL:
Whiteboard:
Depends On:
Blocks: FC6Update
TreeView+ depends on / blocked
 
Reported: 2007-04-02 09:40 UTC by Caolan McNamara
Modified: 2007-11-30 22:12 UTC (History)
1 user (show)

Fixed In Version: 1.7.2-3.fc6
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2007-04-19 08:26:10 UTC


Attachments (Terms of Use)

Description Caolan McNamara 2007-04-02 09:40:25 UTC
Description of problem:
in FC-6/FC-7 in OOo, insert->picture->scan->anything == crash

Version-Release number of selected component (if applicable):
hplib >= 1.6.12

How reproducible:
100%

nm -D ./usr/lib/sane/libsane-hpaio.so.1.0.0 | grep sanei
         U sanei_debug_msg
         U sanei_init_debug

but it doesn't link against libsane, which is fine when it's dlopened from
libsane, but a problem when dlopened from OOo.

Comment 1 Tim Waugh 2007-04-03 11:59:57 UTC
The problem is that SANE doesn't provide any mechanism for building drivers
outside its tree. :-/

I'll take a look at how to fix this.

Comment 2 Tim Waugh 2007-04-03 12:54:30 UTC
Fixed in CVS for FC-6 and devel.

Comment 3 Tim Waugh 2007-04-11 17:09:03 UTC
RHEL-5 is not affected.

Comment 4 Fedora Update System 2007-04-18 22:35:27 UTC
Fixed in update: hplip-1.7.2-3.fc6


Note You need to log in before you can comment on or make changes to this bug.