Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 234798 - gaim beta 6 crashes on startup
Summary: gaim beta 6 crashes on startup
Keywords:
Status: CLOSED NOTABUG
Alias: None
Product: Fedora
Classification: Fedora
Component: gaim
Version: 6
Hardware: i686
OS: Linux
medium
high
Target Milestone: ---
Assignee: Warren Togami
QA Contact:
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2007-04-02 06:38 UTC by Michael de Mare
Modified: 2007-11-30 22:12 UTC (History)
7 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2007-04-09 04:53:19 UTC


Attachments (Terms of Use)
backtrace (deleted)
2007-04-02 18:33 UTC, Michael de Mare
no flags Details

Description Michael de Mare 2007-04-02 06:38:34 UTC
Description of problem:

gaim crashes on startup

Version-Release number of selected component (if applicable):
Gaim 2.0.0-0.31.beta6.fc6

How reproducible:
Every time

Steps to Reproduce:
1. $ gaim -d
2.
3.
  
Actual results:
[mikey@mikey-ws ~]$ gaim -d
dbus: okkk
plugins: probing /usr/lib/gaim/convcolors.so
plugins: probing /usr/lib/gaim/perl.so
plugins: probing /usr/lib/gaim/gaimrc.so
plugins: probing /usr/lib/gaim/autoreply.so
plugins: probing /usr/lib/gaim/libmsn.so
plugins: probing /usr/lib/gaim/offlinemsg.so
plugins: probing /usr/lib/gaim/spellchk.so
plugins: probing /usr/lib/gaim/ssl-nss.so
plugins: probing /usr/lib/gaim/ssl.so
plugins: probing /usr/lib/gaim/extplacement.so
plugins: probing /usr/lib/gaim/idle.so
plugins: probing /usr/lib/gaim/dbus-example.so
plugins: probing /usr/lib/gaim/liboscar.so
plugins: /usr/lib/gaim/liboscar.so is not usable because the 'gaim_init_plugin'
symbol could not be found.  Does the plugin call the GAIM_INIT_PLUGIN() macro?
plugins: probing /usr/lib/gaim/gevolution.so
plugins: probing /usr/lib/gaim/iconaway.so
plugins: probing /usr/lib/gaim/s.so
plugins: /usr/lib/gaim/s.so is not usable because the 'gaim_init_plugin' symbol
could not be found.  Does the plugin call the GAIM_INIT_PLUGIN() macro?
plugins: probing /usr/lib/gaim/musicmessaging.so
plugins: probing /usr/lib/gaim/libicq.so
plugins: probing /usr/lib/gaim/libjabber.so
plugins: probing /usr/lib/gaim/psychic.so
plugins: probing /usr/lib/gaim/xmppconsole.so
plugins: probing /usr/lib/gaim/notify.so
plugins: probing /usr/lib/gaim/libzephyr.so
plugins: probing /usr/lib/gaim/timestamp.so
plugins: probing /usr/lib/gaim/ticker.so
plugins: probing /usr/lib/gaim/newline.so
plugins: probing /usr/lib/gaim/markerline.so
plugins: probing /usr/lib/gaim/buddynote.so
plugins: probing /usr/lib/gaim/libgg.so
plugins: probing /usr/lib/gaim/history.so
plugins: probing /usr/lib/gaim/statenotify.so
plugins: probing /usr/lib/gaim/libnovell.so
plugins: probing /usr/lib/gaim/autoaccept.so
plugins: probing /usr/lib/gaim/log_reader.so
plugins: probing /usr/lib/gaim/libaim.so
plugins: probing /usr/lib/gaim/libqq.so
plugins: probing /usr/lib/gaim/ssl-gnutls.so
plugins: probing /usr/lib/gaim/libirc.so
plugins: probing /usr/lib/gaim/gntlastlog.so
plugins: /usr/lib/gaim/gntlastlog.so is not loadable: undefined symbol: cur_term
plugins: probing /usr/lib/gaim/gnthistory.so
plugins: probing /usr/lib/gaim/libsilcgaim.so
plugins: probing /usr/lib/gaim/gestures.so
plugins: probing /usr/lib/gaim/gntgf.so
plugins: /usr/lib/gaim/gntgf.so is not loadable: The UI requirement is not met.
plugins: probing /usr/lib/gaim/libyahoo.so
plugins: probing /usr/lib/gaim/libsimple.so
plugins: probing /usr/lib/gaim/timestamp_format.so
plugins: probing /usr/lib/gaim/nautilus.so
plugins: /usr/lib/gaim/nautilus.so is not loadable: The UI requirement is not met.
util: Reading file accounts.xml from directory /home/mikey/.gaim
util: Reading file status.xml from directory /home/mikey/.gaim
libnm_glib_nm_state_cb: dbus returned an error.
  (org.freedesktop.DBus.Error.ServiceUnknown) The name
org.freedesktop.NetworkManager was not provided by any .service files
stun: using server
stun: using server
sound: Initializing sound output drivers.
util: Reading file blist.xml from directory /home/mikey/.gaim
prefs: Reading /home/mikey/.gaim/prefs.xml
prefs: Finished reading /home/mikey/.gaim/prefs.xml
plugins: Loading saved plugin /usr/lib/gaim/gevolution.so
plugins: Loading saved plugin /usr/lib/gaim/idle.so
gtkblist: added visibility manager: 1
docklet: created
pounce: Error reading pounces: Failed to open file
'/home/mikey/.gaim/pounces.xml': No such file or directory
Session Management: ICE initialized.
Session Management: Connecting with no previous ID
Session Management: Handling new ICE connection... done.
Session Management: Connected to manager (KDE) with client ID
10e696e2d8000117549576800000036720026
Session Management: Using gaim as command
dbus: Need to register an object with the dbus subsystem.
g_log: file dbus-server.c: line 118 (gaim_dbus_pointer_to_id): should not be reached
account: Connecting to account demaremj
connection: Connecting. gc = 0x86cef78
oscar: registered module misc (family 0xffff, version = 0x0000, tool 0x0000,
tool version 0x0000)
oscar: registered module oservice (family 0x0001, version = 0x0003, tool 0x0110,
tool version 0x0629)
oscar: registered module locate (family 0x0002, version = 0x0001, tool 0x0110,
tool version 0x0629)
oscar: registered module buddy (family 0x0003, version = 0x0001, tool 0x0110,
tool version 0x0629)
oscar: registered module messaging (family 0x0004, version = 0x0001, tool
0x0110, tool version 0x0629)
oscar: registered module advert (family 0x0005, version = 0x0001, tool 0x0001,
tool version 0x0001)
oscar: registered module invite (family 0x0006, version = 0x0001, tool 0x0110,
tool version 0x0629)
oscar: registered module admin (family 0x0007, version = 0x0001, tool 0x0010,
tool version 0x0629)
oscar: registered module popup (family 0x0008, version = 0x0001, tool 0x0104,
tool version 0x0001)
oscar: registered module bos (family 0x0009, version = 0x0001, tool 0x0110, tool
version 0x0629)
oscar: registered module userlookup (family 0x000a, version = 0x0001, tool
0x0110, tool version 0x0629)
oscar: registered module stats (family 0x000b, version = 0x0001, tool 0x0104,
tool version 0x0001)
oscar: registered module translate (family 0x000c, version = 0x0001, tool
0x0104, tool version 0x0001)
oscar: registered module chatnav (family 0x000d, version = 0x0001, tool 0x0010,
tool version 0x0629)
oscar: registered module chat (family 0x000e, version = 0x0001, tool 0x0010,
tool version 0x0629)
oscar: registered module odir (family 0x000f, version = 0x0001, tool 0x0010,
tool version 0x0629)
oscar: registered module bart (family 0x0010, version = 0x0001, tool 0x0010,
tool version 0x0629)
oscar: registered module feedbag (family 0x0013, version = 0x0004, tool 0x0110,
tool version 0x0629)
oscar: registered module icq (family 0x0015, version = 0x0001, tool 0x0110, tool
version 0x047c)
oscar: registered module auth (family 0x0017, version = 0x0000, tool 0x0000,
tool version 0x0000)
oscar: registered module alert (family 0x0018, version = 0x0001, tool 0x0010,
tool version 0x0629)
oscar: Adding handler for ffff/0003
oscar: Adding handler for ffff/0006
oscar: Adding handler for 0007/0003
oscar: Adding handler for 0007/0005
oscar: Adding handler for 0007/0007
oscar: Adding handler for 0018/0001
oscar: Adding handler for 0018/0007
oscar: Adding handler for 0017/0003
oscar: Adding handler for 0017/0007
oscar: Adding handler for 0017/000a
oscar: Adding handler for 0010/0001
oscar: Adding handler for 0010/0005
oscar: Adding handler for 0009/0001
oscar: Adding handler for 0009/0003
oscar: Adding handler for 0003/0001
oscar: Adding handler for 0003/0003
oscar: Adding handler for 0003/000b
oscar: Adding handler for 0003/000c
oscar: Adding handler for 000e/0001
oscar: Adding handler for 000e/0003
oscar: Adding handler for 000e/0004
oscar: Adding handler for 000e/0002
oscar: Adding handler for 000e/0006
oscar: Adding handler for 000d/0001
oscar: Adding handler for 000d/0009
oscar: Adding handler for 0013/0001
oscar: Adding handler for 0013/0003
oscar: Adding handler for 0013/0006
oscar: Adding handler for 0013/000e
oscar: Adding handler for 0013/0008
oscar: Adding handler for 0013/0015
oscar: Adding handler for 0013/0019
oscar: Adding handler for 0013/001b
oscar: Adding handler for 0013/001c
oscar: Adding handler for 0004/0005
oscar: Adding handler for 0004/0007
oscar: Adding handler for 0004/000a
oscar: Adding handler for 0004/000b
oscar: Adding handler for 0004/0001
oscar: Adding handler for 0004/0014
oscar: Adding handler for 0004/000c
oscar: Adding handler for 0015/00f0
oscar: Adding handler for 0015/00f1
oscar: Adding handler for 0015/00f3
oscar: Adding handler for 0015/00f2
oscar: Adding handler for 0002/0003
oscar: Adding handler for 0002/0006
oscar: Adding handler for 0002/0001
oscar: Adding handler for 0002/fffd
oscar: Adding handler for 0001/0001
oscar: Adding handler for 0001/000f
oscar: Adding handler for 0001/001f
oscar: Adding handler for 0001/0021
oscar: Adding handler for 0001/000a
oscar: Adding handler for 0001/0005
oscar: Adding handler for 0001/0013
oscar: Adding handler for 0001/0010
oscar: Adding handler for 0008/0002
oscar: Adding handler for 000a/0001
oscar: Adding handler for 000a/0003
oscar: oscar_login: gc = 0x86cef78
dns: DNS query for 'login.oscar.aol.com' queued
account: Connecting to account 401331842
connection: Connecting. gc = 0x86bd878
oscar: registered module misc (family 0xffff, version = 0x0000, tool 0x0000,
tool version 0x0000)
oscar: registered module oservice (family 0x0001, version = 0x0003, tool 0x0110,
tool version 0x0629)
oscar: registered module locate (family 0x0002, version = 0x0001, tool 0x0110,
tool version 0x0629)
oscar: registered module buddy (family 0x0003, version = 0x0001, tool 0x0110,
tool version 0x0629)
oscar: registered module messaging (family 0x0004, version = 0x0001, tool
0x0110, tool version 0x0629)
oscar: registered module advert (family 0x0005, version = 0x0001, tool 0x0001,
tool version 0x0001)
oscar: registered module invite (family 0x0006, version = 0x0001, tool 0x0110,
tool version 0x0629)
oscar: registered module admin (family 0x0007, version = 0x0001, tool 0x0010,
tool version 0x0629)
oscar: registered module popup (family 0x0008, version = 0x0001, tool 0x0104,
tool version 0x0001)
oscar: registered module bos (family 0x0009, version = 0x0001, tool 0x0110, tool
version 0x0629)
oscar: registered module userlookup (family 0x000a, version = 0x0001, tool
0x0110, tool version 0x0629)
oscar: registered module stats (family 0x000b, version = 0x0001, tool 0x0104,
tool version 0x0001)
oscar: registered module translate (family 0x000c, version = 0x0001, tool
0x0104, tool version 0x0001)
oscar: registered module chatnav (family 0x000d, version = 0x0001, tool 0x0010,
tool version 0x0629)
oscar: registered module chat (family 0x000e, version = 0x0001, tool 0x0010,
tool version 0x0629)
oscar: registered module odir (family 0x000f, version = 0x0001, tool 0x0010,
tool version 0x0629)
oscar: registered module bart (family 0x0010, version = 0x0001, tool 0x0010,
tool version 0x0629)
oscar: registered module feedbag (family 0x0013, version = 0x0004, tool 0x0110,
tool version 0x0629)
oscar: registered module icq (family 0x0015, version = 0x0001, tool 0x0110, tool
version 0x047c)
oscar: registered module auth (family 0x0017, version = 0x0000, tool 0x0000,
tool version 0x0000)
oscar: registered module alert (family 0x0018, version = 0x0001, tool 0x0010,
tool version 0x0629)
oscar: Adding handler for ffff/0003
oscar: Adding handler for ffff/0006
oscar: Adding handler for 0007/0003
oscar: Adding handler for 0007/0005
oscar: Adding handler for 0007/0007
oscar: Adding handler for 0018/0001
oscar: Adding handler for 0018/0007
oscar: Adding handler for 0017/0003
oscar: Adding handler for 0017/0007
oscar: Adding handler for 0017/000a
oscar: Adding handler for 0010/0001
oscar: Adding handler for 0010/0005
oscar: Adding handler for 0009/0001
oscar: Adding handler for 0009/0003
oscar: Adding handler for 0003/0001
oscar: Adding handler for 0003/0003
oscar: Adding handler for 0003/000b
oscar: Adding handler for 0003/000c
oscar: Adding handler for 000e/0001
oscar: Adding handler for 000e/0003
oscar: Adding handler for 000e/0004
oscar: Adding handler for 000e/0002
oscar: Adding handler for 000e/0006
oscar: Adding handler for 000d/0001
oscar: Adding handler for 000d/0009
oscar: Adding handler for 0013/0001
oscar: Adding handler for 0013/0003
oscar: Adding handler for 0013/0006
oscar: Adding handler for 0013/000e
oscar: Adding handler for 0013/0008
oscar: Adding handler for 0013/0015
oscar: Adding handler for 0013/0019
oscar: Adding handler for 0013/001b
oscar: Adding handler for 0013/001c
oscar: Adding handler for 0004/0005
oscar: Adding handler for 0004/0007
oscar: Adding handler for 0004/000a
oscar: Adding handler for 0004/000b
oscar: Adding handler for 0004/0001
oscar: Adding handler for 0004/0014
oscar: Adding handler for 0004/000c
oscar: Adding handler for 0015/00f0
oscar: Adding handler for 0015/00f1
oscar: Adding handler for 0015/00f3
oscar: Adding handler for 0015/00f2
oscar: Adding handler for 0002/0003
oscar: Adding handler for 0002/0006
oscar: Adding handler for 0002/0001
oscar: Adding handler for 0002/fffd
oscar: Adding handler for 0001/0001
oscar: Adding handler for 0001/000f
oscar: Adding handler for 0001/001f
oscar: Adding handler for 0001/0021
oscar: Adding handler for 0001/000a
oscar: Adding handler for 0001/0005
oscar: Adding handler for 0001/0013
oscar: Adding handler for 0001/0010
oscar: Adding handler for 0008/0002
oscar: Adding handler for 000a/0001
oscar: Adding handler for 000a/0003
oscar: oscar_login: gc = 0x86bd878
dns: DNS query for 'login.oscar.aol.com' queued
account: Connecting to account college_boy_cb
connection: Connecting. gc = 0x86be808
yahoo: buddy icon is up to date. Not reuploading.
dns: DNS query for 'scs.msg.yahoo.com' queued

[at this point gaim is up but doesn't respond or display menus or buddies]

Expected results:

expect gaim to come up and display buddies

Additional info:

Comment 1 Warren Togami 2007-04-02 14:07:00 UTC
rpm -qa 'gaim*'

Please paste the output of this.

Comment 2 Michael de Mare 2007-04-02 14:10:23 UTC
[mikey@mikey-ws ~]$ rpm -qa 'gaim*'
gaim-2.0.0-0.31.beta6.fc6
[mikey@mikey-ws ~]$


Comment 3 Warren Togami 2007-04-02 14:12:08 UTC
http://gaim.sourceforge.net/gdb.php
Please get a gdb backtrace using this procedure after you have installed a
matching gaim-debuginfo.  DO NOT PASTE the result here.  Attach it.

Comment 4 Tim Niemueller 2007-04-02 15:10:53 UTC
The problem goes away if I disable the Galago plugin by removing the appropriate
line from ~/.gaim/prefs.xml.

Comment 5 Michael de Mare 2007-04-02 15:17:53 UTC
I don't seem to have anything in my prefs.xml refering to Galago.


Comment 6 Michael de Mare 2007-04-02 18:33:09 UTC
Created attachment 151454 [details]
backtrace


I don't know how useful this will be since it freezes up rather than bombing.

Comment 7 Mark Doliner 2007-04-02 20:13:37 UTC
The backtrace from comment #6 looks like it was triggered by Gaim's Evolution
address book plugin.

Comment 8 Michael de Mare 2007-04-02 20:27:29 UTC
Deleting Evolution from prefs.xml fixes it.  I also notice that Evolution isn't
working.




Note You need to log in before you can comment on or make changes to this bug.