Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 234779 - mkinitrd should not try to find "dmsetup table" name in dmraid output
Summary: mkinitrd should not try to find "dmsetup table" name in dmraid output
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: Fedora
Classification: Fedora
Component: mkinitrd
Version: 6
Hardware: All
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Peter Jones
QA Contact: David Lawrence
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2007-04-01 22:23 UTC by Olivier Kurzweg
Modified: 2007-11-30 22:12 UTC (History)
0 users

Fixed In Version: fc8
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2007-11-17 18:51:27 UTC


Attachments (Terms of Use)

Description Olivier Kurzweg 2007-04-01 22:23:12 UTC
Description of problem:
From time to time, my sil RAID1 array gets out of sync and I need to rebuild the
array. When this happens, an new name gets generated for it: name sil_xxxxxxxxx
changes to sil_yyyyyyyyyy. Since the init script still has reference to the old
name, block devices get created with the old name at boot time.

'dmsetup table' returns "sil_xxxxxxxxxx". But dmraid returns "sil_yyyyyyyyyyyy".

In that situation, mkinitrd will fail to add the necessary 'dm create' lines in
the init script: it looks up for entries from the "dmestup table" that match
entries from the "dmraid -s" output and finds none.

Workaround: run a 'dmsetup rename sil_xxxxxxxxxx sil_yyyyyyyyyyyy' before
running mkinitrd.


Version-Release number of selected component (if applicable):
5.1.19.0.3-1

Steps to Reproduce:
1. Break and rebuild raid array (new name gets generated)
2. Run mkinitrd
  
Actual results:
mkinitrd does not "see" the new array and do not add the 'dm create' lines in
the init script  

Expected results:
mkinitrd should not rely on the name returned by dmsetup table, or should not
try to find a match in the output of dmraid -s

Comment 1 Olivier Kurzweg 2007-11-17 18:51:27 UTC
Got fixed somewhen between fc6 and fc8


Note You need to log in before you can comment on or make changes to this bug.