Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 234763 - Gnumeric can't open Excel files
Summary: Gnumeric can't open Excel files
Alias: None
Product: Fedora
Classification: Fedora
Component: gnumeric
Version: rawhide
Hardware: All
OS: Linux
Target Milestone: ---
Assignee: Hans de Goede
QA Contact: Fedora Extras Quality Assurance
Depends On:
TreeView+ depends on / blocked
Reported: 2007-04-01 17:37 UTC by William Lovaton
Modified: 2007-11-30 22:12 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Last Closed: 2007-04-10 18:17:38 UTC

Attachments (Terms of Use)
strace log (deleted)
2007-04-08 19:10 UTC, William Lovaton
no flags Details

Description William Lovaton 2007-04-01 17:37:09 UTC
Description of problem:
Gnumeric can't open Excel files, it shows the following window message:
"Unsupported file format."

After clicking "Close" it then opens an empty Gnumeric session.

The funny thing is that running Fedora 7 Test 3 Live CD it works fine and I am
opening the exact same file from a USB memory.

My system was installed originally with Test 2 Live CD and then updated as of
today April 1.

Version-Release number of selected component (if applicable):
This is weird because Test 3 Live CD uses exactly the same version and it works
there.  Maybe I'm missing a package... right?

How reproducible:

Steps to Reproduce:
1. Try opening a .xls file

Comment 1 Hans de Goede 2007-04-03 05:52:54 UTC
Interesting problem, which I cannot reproduce, can you try stracing gnumeric? At
the cmdline prompt "$" type:
"strace gnumeric foo.xls &> log"

And then attach the generated log file here.

Comment 2 William Lovaton 2007-04-08 19:10:13 UTC
Created attachment 151934 [details]
strace log

Hi there, sorry for the late response, I was out of town.

I haven't applied the new updates yet so this strace log is from updates as of
April 01.  I tried avoiding spaces in the file path and still nothing.	The
trace includes clicking in the "Close" button of the message window and then
closing the empty gnumeric session from the X button in the window manager.


Comment 3 Hans de Goede 2007-04-08 20:04:46 UTC

I can see gnumeric statting but not loading any plugins. Can you start gnumeric
and then goto: tools->plugins

And then see if "MS excel" is in the plugin list, and if it is there, if its
enabled. If its not enabled try enabling it. Also interesting would be the
"activate new plugins by default" checkbox value

Comment 4 William Lovaton 2007-04-10 14:25:22 UTC
That's right.  I checked this option and it works now.

Curiously, there are a lot of options and none of them are selected.  My Ubuntu
system in my laptop have almost all of them selected.

I don't know how this happened, I suppose they should be activated by default.

I think it is safe to close this bug report now.

Comment 5 Hans de Goede 2007-04-10 18:17:38 UTC
Hmm, strange I just nuked my gnumeric config dir ( ~/.gconf/apps/gnumeric) and
then started gnumeric fresh, and it did have the "activate new plugins by
default" checkbox enabled by default and it worked fine with xls files without
any configuring. I don't know what went wrong in your setup, closing.

Note You need to log in before you can comment on or make changes to this bug.