Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 234738 - lyx: can not generate latex output
Summary: lyx: can not generate latex output
Keywords:
Status: CLOSED UPSTREAM
Alias: None
Product: Fedora
Classification: Fedora
Component: lyx
Version: rawhide
Hardware: All
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Rex Dieter
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2007-04-01 08:45 UTC by Trond Danielsen
Modified: 2007-11-30 22:12 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2007-04-02 19:10:18 UTC


Attachments (Terms of Use)
Lyx file that fails. (deleted)
2007-04-01 08:45 UTC, Trond Danielsen
no flags Details

Description Trond Danielsen 2007-04-01 08:45:40 UTC
Description of problem:
The current version of lyx cannot generate pdf pr latex output of the included file

Version-Release number of selected component (if applicable):
Name   : lyx
Arch   : i386
Version: 1.5.0
Release: 0.2.beta1.fc7


How reproducible:
Every time.

Steps to Reproduce:
1. Download sdccman.lyx
2. Run lyx -e latex sdccman.lyx or lyx -e pdf sdccman.lyx
  
Actual results:
lyx fails because of an iconv file format conversion problem.

Expected results:
pdf or latex output.

Additional info:

Comment 1 Trond Danielsen 2007-04-01 08:45:41 UTC
Created attachment 151377 [details]
Lyx file that fails.

Comment 2 Trond Danielsen 2007-04-01 09:41:59 UTC
Apparently, the bug has been fixed upsteam: http://www.lyx.org/trac/changeset/17666

Comment 3 Rex Dieter 2007-04-02 12:22:19 UTC
That changeset was/is a fix for running lyx under qt-4.3 (and qt-4.3 isn't in 
F7 yet).  Doesn't appear to be related to *this*.  I'll try rebuilding with 
the patch to double-check.

Regardless, this look like a good candidate to file upstream.

Comment 4 Rex Dieter 2007-04-02 18:03:45 UTC
confirmed patch helps qt-4.3 compatibility, but doesn't help here.

Comment 5 Rex Dieter 2007-04-02 18:06:05 UTC
when/if you report upstream, please document it here, else I'll report it myself
later this week.

Comment 6 Trond Danielsen 2007-04-02 19:10:18 UTC
I am not that familiar with lyx, as it is only a requirement to build the
documentation for sdcc, so I would prefer if you could handle the communication
with upstream.

Comment 7 Rex Dieter 2007-04-03 19:57:25 UTC
Reported upstream:
http://bugzilla.lyx.org/show_bug.cgi?id=3417


Note You need to log in before you can comment on or make changes to this bug.