Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 234735 - [mmconf] USB keyboard keystrokes are missed or repeated on virtual terminals
Summary: [mmconf] USB keyboard keystrokes are missed or repeated on virtual terminals
Alias: None
Product: Fedora
Classification: Fedora
Component: kernel
Version: rawhide
Hardware: i686
OS: Linux
Target Milestone: ---
Assignee: Kernel Maintainer List
QA Contact: Brian Brock
Whiteboard: bzcl34nup
Depends On:
TreeView+ depends on / blocked
Reported: 2007-04-01 03:13 UTC by Jacob Thompson
Modified: 2008-05-07 01:23 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Last Closed: 2008-05-07 01:23:58 UTC

Attachments (Terms of Use)

Description Jacob Thompson 2007-04-01 03:13:51 UTC
Description of problem:
On a virtual terminal console, using a USB keyboard, typing on the keyboard
either causes missed keystrokes and requires holding down every key for ~1/2
sec. (like typing on a mechanical typewriter), or repeats keystrokes (lliikkee 

When using the X Window System, the same USB keyboard works perfectly fine.

Version-Release number of selected component (if applicable):
Fedora release 6.92 (Rawhide)
Linux localhost.localdomain 2.6.20-1.3023.fc7 #1 SMP Sun Mar 25 22:12:02 EDT
2007 i686 i686 i386 GNU/Linux
input: USB HID v1.10 Keyboard [LITEON Technology USB Keyboard] on usb-0000:00:1d.0-1

How reproducible:
Attempt to type on a virtual terminal console

Steps to Reproduce:
1. Press Ctrl-Alt-F1
2. Try to login at a normal typing speed
Actual results:
Keystrokes are missed or repeated

Expected results:
Keystrokes captured as typed

Additional info:
Works in X

Comment 1 Pete Zaitcev 2007-04-01 05:09:47 UTC
This does not sound like a kernel issue to me. Most likely, either X or
something else is keeping /dev/kbd open, or something similar is happening.
There was some strangenness recently due to switch of X configuration
tools to evdev.

Please try to log over the network while the symptom is present and
poke around with lsof.

Comment 2 Jacob Thompson 2007-04-01 11:42:46 UTC
I logged into the machine over a null modem cable while running X and at the
console, there is no device containing "kbd" open and in fact, there is no such
file /dev/kbd.  The issue also goes away when using a PS/2 keyboard.

I also tried rebooting with init=/bin/cat on the kernel command line so that no
daemons would be running trying to access the keyboard.  With just cat running,
the problem is even worse, I get tteeeeeeeesssssssstttttttt.

Since this is a 64-bit machine, I tried booting the x86_64 kernel from a USB
key.  The problem is still there.  It occurs with the kernel on Fedora 7 test 3
LiveCD, the Fedora 7 test 3 bootdisk.img for both i386 and x86_64, as well as on
the original Fedora Core 6 install CD (2.6.18?).

On this machine, I have to boot with acpi=off, reported in bug 234733.  Could
this be related?

Comment 3 Matthew Miller 2007-04-10 15:54:02 UTC
Bulk message: Fedora 7 test bugs should be filed against "devel", not against
test1/2/3. This isn't obvious, I know. Moving this report so it isn't lost.

Comment 4 Jacob Thompson 2007-10-06 21:31:27 UTC
This problem is not happening anymore with current kernels using the boot option
with the option pci=nommconf.

Comment 5 Bug Zapper 2008-04-03 23:53:25 UTC
Based on the date this bug was created, it appears to have been reported
against rawhide during the development of a Fedora release that is no
longer maintained. In order to refocus our efforts as a project we are
flagging all of the open bugs for releases which are no longer
maintained. If this bug remains in NEEDINFO thirty (30) days from now,
we will automatically close it.

If you can reproduce this bug in a maintained Fedora version (7, 8, or
rawhide), please change this bug to the respective version and change
the status to ASSIGNED. (If you're unable to change the bug's version
or status, add a comment to the bug and someone will change it for you.)

Thanks for your help, and we apologize again that we haven't handled
these issues to this point.

The process we're following is outlined here:

We will be following the process here: to ensure this
doesn't happen again.

Comment 6 Bug Zapper 2008-05-07 01:23:56 UTC
This bug has been in NEEDINFO for more than 30 days since feedback was
first requested. As a result we are closing it.

If you can reproduce this bug in the future against a maintained Fedora
version please feel free to reopen it against that version.

The process we're following is outlined here:

Note You need to log in before you can comment on or make changes to this bug.