Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 234730 - Unable to assign permissions to a folder as root.
Summary: Unable to assign permissions to a folder as root.
Keywords:
Status: CLOSED NOTABUG
Alias: None
Product: Fedora
Classification: Fedora
Component: coreutils
Version: 6
Hardware: All
OS: Linux
medium
urgent
Target Milestone: ---
Assignee: Tim Waugh
QA Contact:
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2007-04-01 00:25 UTC by James Roffino
Modified: 2007-11-30 22:12 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2007-04-03 12:39:04 UTC


Attachments (Terms of Use)

Description James Roffino 2007-04-01 00:25:46 UTC
Description of problem:

As the root user, I am unable to change the permissions associated with a
folder. I get the message "you do not have the permissions to do that" when I
attempt to. further attempts using commands on the command line are documented here:

http://forum.fedoraforum.org/showthread.php?p=770151#post770151

I am NOT a veteran linux user so I have absolutely NO fucking clue what to do.
It really frustrates me that there's nowhere to turn to when I get a problem
like this.  I'm hoping that this will be read by a human being capable of
understanding how frustrating this is. I do not know ANYTHING about any of the
other things on this damn web page and I have no idea how to categorize my
problem.  I chose the first thing listed because there's a list of thousands of
completely nonsensical words and I don't know anything about any of them.

Version-Release number of selected component (if applicable):


How reproducible:


Steps to Reproduce:
1.
2.
3.
  
Actual results:


Expected results:


Additional info:

Comment 1 Tim Waugh 2007-04-03 12:39:04 UTC
"I think eris is a vfat partition."

VFAT has no concept of owners or groups, so all files in that filesystem get a
particular ownership when the filesystem is mounted.  See the 'man mount' man
page, under the section 'Mount options for fat':

       uid=value and gid=value
              Set the owner and group of all files.  (Default: the uid and gid
              of the current process.)

So you need to edit your /etc/fstab to add the correct uid= and gid= options for
your /eris entry, something like:

/dev/hda1  /eris  vfat  uid=500,gid=500  1 2

The 'uid=500,gid=500' is the important bit, and you'll need to put the correct
UID and GID values in there.

For questions about how to do this, why it is necessary, etc, you should ask on
the fedora-list mailing list, where there are other people who may have come
across similar situations:

https://www.redhat.com/mailman/listinfo/fedora-list


Note You need to log in before you can comment on or make changes to this bug.