Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 234729 - Installer crashes because of empty drivelist in VMware 5.5.3
Summary: Installer crashes because of empty drivelist in VMware 5.5.3
Keywords:
Status: CLOSED DUPLICATE of bug 234697
Alias: None
Product: Fedora
Classification: Fedora
Component: anaconda
Version: rawhide
Hardware: All
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Anaconda Maintenance Team
QA Contact:
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2007-03-31 22:53 UTC by Sascha Zorn
Modified: 2007-11-30 22:12 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2007-04-02 17:21:07 UTC


Attachments (Terms of Use)

Description Sascha Zorn 2007-03-31 22:53:07 UTC
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.8.1.3) Gecko/20070309 Firefox/2.0.0.3

Description of problem:
I created a VMware with all standard options, and the installer crashes, because it can not find any drive. After changed the disc from SCSI to IDE, it works. I dont know why the installer doesn't find the disc, but i've seen the reason, the installer just crashes, instead of showing an error message!

Line 286 in /anaconda/iw/autopart_type.py
defaultBoot = self.anaconda.id.bootloader.drivelist[0]
IndexError: list index out of range

I guess there is no entry in this array.
I dont know how the devices are initialized in the bootimage(/dev/sda?)...the mptspi kernel module for the SCSI controller is running, but there are no sda entries! Is this correct? Shouldn't there be an device node anywhere?

Version-Release number of selected component (if applicable):


How reproducible:
Always


Steps to Reproduce:
1. Create standard VMware
2. Boot into the installer
3. Press next two times.

Actual Results:


Expected Results:


Additional info:

Comment 1 Jeremy Katz 2007-04-02 17:21:07 UTC
Fixed the traceback; the problem is that the kernel isn't working with the
vmware scsi emulation. 

*** This bug has been marked as a duplicate of 234697 ***


Note You need to log in before you can comment on or make changes to this bug.