Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 234694 - After reopening folder, background color becomes initial.
Summary: After reopening folder, background color becomes initial.
Keywords:
Status: CLOSED RAWHIDE
Alias: None
Product: Fedora
Classification: Fedora
Component: eel2
Version: rawhide
Hardware: All
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Søren Sandmann Pedersen
QA Contact:
URL:
Whiteboard:
: 238773 (view as bug list)
Depends On:
Blocks: FC7Target
TreeView+ depends on / blocked
 
Reported: 2007-03-31 12:36 UTC by sangu
Modified: 2014-06-18 09:09 UTC (History)
3 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2007-05-03 18:56:17 UTC


Attachments (Terms of Use)

Description sangu 2007-03-31 12:36:11 UTC
Description of problem:

After reopening folder, background color becomes initial.
But, Patterns works well.

Version-Release number of selected component (if applicable):
2.18.0.1-2.fc7

How reproducible:
always

Steps to Reproduce:
1.  drag and drop a color to a  nautilus folder.
2.  drag and drop Reset to the nautilus folder.
3.
  
Actual results:


Expected results:


Additional info:
eel2-2.18.0.1-3.fc7

Comment 1 Alexander Larsson 2007-04-02 11:43:14 UTC
soeren, this is probably more fallout from your eelbackground patches.

Comment 2 Matthias Clasen 2007-04-18 05:07:51 UTC
Looks like this is because eel_background_ensure_realized() ends up always
making the current color the default. I think what is intended here is to only
set the default color once ?

Comment 3 Søren Sandmann Pedersen 2007-05-03 18:51:33 UTC
*** Bug 238773 has been marked as a duplicate of this bug. ***

Comment 4 Søren Sandmann Pedersen 2007-05-03 18:56:17 UTC
This should be fixed in tomorrow's rawhide.


Note You need to log in before you can comment on or make changes to this bug.