Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 234680 - Yumex ignores theme settings = unusable
Summary: Yumex ignores theme settings = unusable
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: Fedora
Classification: Fedora
Component: yumex
Version: 6
Hardware: All
OS: Linux
medium
low
Target Milestone: ---
Assignee: Tim Lauridsen
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2007-03-31 04:23 UTC by jerrycasiano
Modified: 2007-11-30 22:12 UTC (History)
0 users

Fixed In Version: 1.9.10
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2007-07-30 10:41:00 UTC


Attachments (Terms of Use)
Screenshot of Yumex appearance with a dark theme. (deleted)
2007-03-31 04:23 UTC, jerrycasiano
no flags Details
Screenshot of Yumex appearance with High Contrast Inverse theme (deleted)
2007-03-31 04:32 UTC, jerrycasiano
no flags Details

Description jerrycasiano 2007-03-31 04:23:36 UTC
Description of problem: 

Yumex ignores certain theme settings, which makes it impossible see text.

Version-Release number of selected component (if applicable):

1.9.4 

How reproducible:

Every time

Steps to Reproduce:

1.Select a dark theme, or if one is not available select High Contrast Inverse.

2.Attempt to use yumex.

3.Be frustrated. :p
  
Actual results:

Yumex ignores theme values and defaults to using certain colors in order to
allow users to distinguish packages between updates, available and installed,
which is a nice thought, but fails in practice if a user is using a dark theme
since text blends into the background and becomes unreadable.

Expected results:

That yum either respect current theme values or completely disregard them,
adding a fallback list of colors for dark or High Contrast themes would be a
nice touch but changing the text colors to something that works well with both
might be easier.


Additional info:

Getting the left side panel to blend in also would be awesome, I was able to
change it through gtkrc but not without breaking a bunch of other stuff.
Maybe where it gets it's background info from could be changed?

Comment 1 jerrycasiano 2007-03-31 04:23:37 UTC
Created attachment 151342 [details]
Screenshot of Yumex appearance with a dark theme.

Comment 2 jerrycasiano 2007-03-31 04:32:46 UTC
Created attachment 151343 [details]
Screenshot of Yumex appearance with High Contrast Inverse theme

Comment 3 Tim Lauridsen 2007-03-31 07:08:38 UTC
I can see the problem, i dont think i can read the theme value, without making
yumex depend to much on gnome, it will not nice for the people running xfce &
kde, if yumex need gnome to work.
But i will make the colors configurable.

Comment 4 jerrycasiano 2007-03-31 21:41:56 UTC
Thank you.

Comment 5 Tim Lauridsen 2007-06-22 12:03:01 UTC
I have added some options to /etc/yumex.conf to control the colors of the
packages in the package view

http://www.yum-extender.org/wiki/Yumex/Doc/YumexConf#head-2d3960ed47e05021a376209354fc65771cb83e9f

It will be available in yumex-1.9.10.


Note You need to log in before you can comment on or make changes to this bug.