Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 234597 - xen initscript runs on every runlevel change because it doesn't write a lock file
Summary: xen initscript runs on every runlevel change because it doesn't write a lock ...
Keywords:
Status: CLOSED RAWHIDE
Alias: None
Product: Fedora
Classification: Fedora
Component: xen
Version: rawhide
Hardware: All
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Daniel Berrange
QA Contact: Martin Jenner
URL:
Whiteboard: bzcl34nup
: 217255 (view as bug list)
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2007-03-30 14:03 UTC by Mark McLoughlin
Modified: 2008-05-07 08:01 UTC (History)
5 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2008-05-07 01:22:38 UTC


Attachments (Terms of Use)
xen-initscript-lock.patch (deleted)
2007-05-04 15:42 UTC, Mark McLoughlin
no flags Details | Diff

Description Mark McLoughlin 2007-03-30 14:03:13 UTC
+++ This bug was initially created as a clone of Bug #214503 +++

SSIA.

-- Additional comment from notting@redhat.com on 2006-11-07 16:29 EST --
Created an attachment (id=140604)
patch!

-- Additional comment from veillard@redhat.com on 2006-11-16 05:21 EST --
The other Xen init script /etc/init.d/xendomains need to be checked too

Daniel

Comment 1 Mark McLoughlin 2007-03-30 14:06:32 UTC
*** Bug 217255 has been marked as a duplicate of this bug. ***

Comment 2 Mark McLoughlin 2007-03-30 14:08:49 UTC
Patch looks good, will push to rawhide. Not relevant to upstream, though, since
it's Fedora specific.

The xendomains script seems to do this fine.

Comment 3 Mark McLoughlin 2007-05-04 15:42:17 UTC
Created attachment 154133 [details]
xen-initscript-lock.patch

Comment 4 Mark McLoughlin 2007-05-04 15:43:57 UTC
Okay, attached a version which applies against our 3.0.5-rc4 in rawhide

Re-assigned to dan to include in the next build

Comment 5 Red Hat Bugzilla 2007-07-25 00:07:05 UTC
change QA contact

Comment 6 Bug Zapper 2008-04-03 23:51:18 UTC
Based on the date this bug was created, it appears to have been reported
against rawhide during the development of a Fedora release that is no
longer maintained. In order to refocus our efforts as a project we are
flagging all of the open bugs for releases which are no longer
maintained. If this bug remains in NEEDINFO thirty (30) days from now,
we will automatically close it.

If you can reproduce this bug in a maintained Fedora version (7, 8, or
rawhide), please change this bug to the respective version and change
the status to ASSIGNED. (If you're unable to change the bug's version
or status, add a comment to the bug and someone will change it for you.)

Thanks for your help, and we apologize again that we haven't handled
these issues to this point.

The process we're following is outlined here:
http://fedoraproject.org/wiki/BugZappers/F9CleanUp

We will be following the process here:
http://fedoraproject.org/wiki/BugZappers/HouseKeeping to ensure this
doesn't happen again.

Comment 7 Bug Zapper 2008-05-07 01:22:36 UTC
This bug has been in NEEDINFO for more than 30 days since feedback was
first requested. As a result we are closing it.

If you can reproduce this bug in the future against a maintained Fedora
version please feel free to reopen it against that version.

The process we're following is outlined here:
http://fedoraproject.org/wiki/BugZappers/F9CleanUp

Comment 8 Mark McLoughlin 2008-05-07 08:01:17 UTC
This looks fine in F-9 with the new xend initscript


Note You need to log in before you can comment on or make changes to this bug.