Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 234588 - CPU flags too large for Oracle Insert
Summary: CPU flags too large for Oracle Insert
Keywords:
Status: CLOSED DUPLICATE
Alias: None
Product: Red Hat Satellite 5
Classification: Red Hat
Component: Registration
Version: unspecified
Hardware: i386
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Bret McMillan
QA Contact: Corey Welton
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2007-03-30 12:13 UTC by paul boin
Modified: 2007-10-24 02:04 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2007-04-10 14:47:24 UTC


Attachments (Terms of Use)

Description paul boin 2007-03-30 12:13:19 UTC
Description of problem:
-----------------------

Registering with hardware profile fails.  CPU flags are more bytes than the
Oracle table is defined for.

Suggested Action:
-----------------
Allow for more bytes in rhnCPU.flags column.

Version-Release
---------------
Satellite is 4.2.0

Error on client:
----------------

# up2date --hardware
Updating hardware profile...
An error has occurred:
Internal Server Error
See /var/log/up2date for more information



From /var/log/up2date on client:
--------------------------------

[Fri Mar 30 07:34:24 2007] up2date updating login info
[Fri Mar 30 07:34:24 2007] up2date logging into up2date server
[Fri Mar 30 07:34:24 2007] up2date successfully retrieved authentication token
from up2date server
[Fri Mar 30 07:34:25 2007] up2date Internal Server Error
[Fri Mar 30 07:34:25 2007] up2date   File "/usr/sbin/up2date", line 1288, in ?
    sys.exit(main() or 0)
   File "/usr/sbin/up2date", line 549, in main
    rhnHardware.updateHardware()
   File "/usr/share/rhn/up2date_client/rhnHardware.py", line 13, in updateHardware
    hardwareList)
   File "/usr/lib/python2.3/xmlrpclib.py", line 1029, in __call__
    return self.__send(self.__name, args)
   File "/usr/share/rhn/up2date_client/rpcServer.py", line 46, in _request1
    ret = self._request(methodname, params)
   File "/usr/lib/python2.3/site-packages/rhn/rpclib.py", line 323, in _request
    raise pe


/proc/cpuinfo on client:
------------------------

# cat /proc/cpuinfo
processor       : 0
vendor_id       : GenuineIntel
cpu family      : 6
model           : 15
model name      : Intel(R) Xeon(R) CPU            3070  @ 2.66GHz
stepping        : 6
cpu MHz         : 2666.819
cache size      : 4096 KB
physical id     : 0
siblings        : 2
core id         : 0
cpu cores       : 2
fdiv_bug        : no
hlt_bug         : no
f00f_bug        : no
coma_bug        : no
fpu             : yes
fpu_exception   : yes
cpuid level     : 10
wp              : yes
flags           : fpu vme de pse tsc msr pae mce cx8 apic sep mtrr pge mca
cmovpat pse36 clflush dts acpi mmx fxsr sse sse2 ss ht tm pbe nx lm constant_tsc
pni monitor ds_cpl vmx est tm2 ssse3 cx16 xtpr lahf_lm
bogomips        : 5336.55
clflush size    : 64

processor       : 1
vendor_id       : GenuineIntel
cpu family      : 6
model           : 15
model name      : Intel(R) Xeon(R) CPU            3070  @ 2.66GHz
stepping        : 6
cpu MHz         : 2666.819
cache size      : 4096 KB
physical id     : 0
siblings        : 2
core id         : 1
cpu cores       : 2
fdiv_bug        : no
hlt_bug         : no
f00f_bug        : no
coma_bug        : no
fpu             : yes
fpu_exception   : yes
cpuid level     : 10
wp              : yes
flags           : fpu vme de pse tsc msr pae mce cx8 apic sep mtrr pge mca
cmovpat pse36 clflush dts acpi mmx fxsr sse sse2 ss ht tm pbe nx lm constant_tsc
pni monitor ds_cpl vmx est tm2 ssse3 cx16 xtpr lahf_lm
bogomips        : 5333.69
clflush size    : 64



From /etc/httpd/logs/error_log on satellite server:
---------------------------------------------------

Exception reported from penguin.arl.army.mil
Time: Sun Mar 25 11:23:05 2007
Exception type server.rhnSQL.sql_base.SQLError
Exception while handling function registration.refresh_hw_profile
Request object information:
URI: /XMLRPC
Remote Host: 128.63.58.149
Server Name: penguin.arl.army.mil:443
Headers passed in:
        Accept-Encoding: identity
        Content-Length: 47890
        Host: penguin.arl.army.mil:443
        content-type: text/xml
        user-agent: rhn.rpclib.py/$Revision: 93032 $
        x-client-version: 1
        x-info: RPC Processor (C) Red Hat, Inc (version 93032)
        x-rhn-client-capability: packages.verifyAll(1)=1,caneatCheese(1)=1,packa
ges.extended_profile(1)=1,reboot.reboot(1)=1,packages.verify(1)=1,packages.runTr
ansaction(1)=1,packages.rollBack(1)=1
        x-rhn-transport-capability: follow-redirects=2
        x-transport-info: Extended Capabilities Transport (C) Red Hat, Inc (vers
ion 93032)
        x-up2date-version: 4.4.69-25
Extra information about this error:
SQL Error generated: (1401, 'ORA-01401: inserted value too large for column\n',
'insert into rhnCPU ( id, cpu_arch_id, server_id, nrcpu, vendor, family, cache,
bogomips, version, mhz, stepping, flags, model ) values ( :p0, :p_cpu_arch_id, :
p_server_id, :p_nrcpu, :p_vendor, :p_family, :p_cache, :p_bogomips, :p_version,
:p_mhz, :p_stepping, :p_flags, :p_model )')

Exception Handler Information
Traceback (most recent call last):
  File "/usr/share/rhn/server/apacheRequest.py", line 108, in call_function
    response = apply(func, params)
  File "/usr/share/rhn/server/handlers/xmlrpc/registration.py", line 485, in ref
resh_hw_profile
    server.save_hardware()
  File "/usr/share/rhn/server/rhnServer/server_wrapper.py", line 81, in save_har
dware
    ret = self.save_hardware_byid(self.server["id"])
  File "/usr/share/rhn/server/rhnServer/server_hardware.py", line 662, in
save_hardware_byid
    hw.save(sysid)
  File "/usr/share/rhn/server/rhnServer/server_hardware.py", line 192, in save
    t[devid] = self.data
  File "/usr/share/rhn/server/rhnSQL/sql_table.py", line 179, in __setitem__
    apply(h.execute, (), pdict)
  File "/usr/share/rhn/server/rhnSQL/int_oracle.py", line 100, in execute
    return apply(self._execute_wrapper, (self._execute, ) + p, kw)
  File "/usr/share/rhn/server/rhnSQL/int_oracle.py", line 132, in _execute_wrapper
    raise apply(sql_base.SQLError, ret)
SQLError: (1401, 'ORA-01401: inserted value too large for column\n', 'insert
into rhnCPU ( id, cpu_arch_id, server_id, nrcpu, vendor, family, cache,
bogomips, version, mhz, stepping, flags, model ) values ( :p0, :p_cpu_arch_id,
:p_server_id, :p_nrcpu, :p_vendor, :p_family, :p_cache, :p_bogomips, :p_version,
:p_mhz, :p_stepping, :p_flags, :p_model )')

Comment 1 Clifford Perry 2007-04-10 14:47:24 UTC

*** This bug has been marked as a duplicate of 224682 ***


Note You need to log in before you can comment on or make changes to this bug.