Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 234586 - rhn-ssl-cert-check doesn't recognise traceback_mail setting in /etc/rhn/rhn.conf
Summary: rhn-ssl-cert-check doesn't recognise traceback_mail setting in /etc/rhn/rhn.conf
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: Red Hat Network
Classification: Red Hat
Component: RHN/Other
Version: rhn410
Hardware: All
OS: Linux
medium
low
Target Milestone: ---
Assignee: Miroslav Suchý
QA Contact: Preethi Thomas
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2007-03-30 11:59 UTC by spark
Modified: 2007-06-26 02:30 UTC (History)
1 user (show)

Fixed In Version: sat500
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2007-06-26 02:30:43 UTC


Attachments (Terms of Use)

Description spark 2007-03-30 11:59:59 UTC
Description of problem:
rhn-ssl-cert-check returns:

"Unable to read the admin e-mail address in /etc/rhn/rhn.conf



To disable monitoring, add CHECK=no in /etc/sysconfig/rhn/rhn-ssl-cert-check

Otherwise, you will have to add a valid email address to receive

expiration notifications, either in /etc/rhn/rhn.conf (traceback_mail)

or set ADMIN in /etc/sysconfig/rhn/rhn-ssl-cert-check
"

even when traceback_mail is correctly set in /etc/rhn/rhn.conf

How reproducible:
Every time on an rhn-proxy system. I can't check, but I assume this wouldn't be
reproducible on a satellite.


Steps to Reproduce:
1. Set traceback_mail in /etc/rhn/rhn.conf and ensure ADMIN is not set in
/etc/sysconfig/rhn/rhn-ssl-cert-check
2. Run /etc/cron.daily/rhn-ssl-cert-check
  
Actual results:
Error shown above

Expected results:
No error

Additional info:
It seems that the cause of the problem is in the script rhn-ssl-cert-check in
the method get_rhn_component (copied below), the check is for rhn-proxy-broker.
This package does not exist -- it is called rhns-proxy-broker.

get_rhn_component() {

    # Identify the RHN component

    if rpm -q rhn-proxy-broker >& /dev/null; then

        echo "proxy.broker"

        return

    elif  rpm -q rhns-satellite-tools >& /dev/null; then

        echo "server.satellite"

        return

    fi

}

Comment 2 Miroslav Suchý 2007-05-02 16:39:15 UTC
Indeed, the bug is there and change from rhn-proxy-broker to rhns-proxy-broker
will fix it. Commited into trunk (rev. 115731).

Comment 3 Miroslav Suchý 2007-05-04 08:05:47 UTC
The package was not build before last push. I build it and we'll need to wait
for next QA push.

Comment 4 Miroslav Suchý 2007-05-09 08:04:01 UTC
moving ON_QA.

Comment 6 Preethi Thomas 2007-05-21 18:41:48 UTC
verified

Comment 7 Preethi Thomas 2007-05-21 18:47:44 UTC
On a second look I need to confirm the steps before I verify it. Putting it back
to on_qa

Comment 8 Preethi Thomas 2007-05-24 13:34:15 UTC
verified

Comment 9 Devan Goodwin 2007-06-20 20:25:05 UTC
On a proxy system:

[root@newman ~]# sh /etc/cron.daily/rhn-ssl-cert-check
[root@newman ~]# 

Moving to release pending.

Comment 10 Brandon Perkins 2007-06-26 02:30:43 UTC
Closed for Satellite 500 Release.


Note You need to log in before you can comment on or make changes to this bug.