Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 234580 - Unused var in alloc_ldt()
Summary: Unused var in alloc_ldt()
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Enterprise Linux 4
Classification: Red Hat
Component: kernel
Version: 4.4
Hardware: i386
OS: Linux
medium
low
Target Milestone: ---
: ---
Assignee: Jerome Marchand
QA Contact: Martin Jenner
URL:
Whiteboard:
: 246109 (view as bug list)
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2007-03-30 09:34 UTC by Jerome Marchand
Modified: 2007-11-17 01:14 UTC (History)
1 user (show)

Fixed In Version: RHBA-2007-0791
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2007-11-15 16:24:17 UTC


Attachments (Terms of Use)
patch file (deleted)
2007-03-30 09:34 UTC, Jerome Marchand
no flags Details


Links
System ID Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2007:0791 normal SHIPPED_LIVE Updated kernel packages available for Red Hat Enterprise Linux 4 Update 6 2007-11-14 18:25:55 UTC

Description Jerome Marchand 2007-03-30 09:34:57 UTC
Description of problem:
The declaration and one assignment of the unused oldsize variable remain. This
variable is unused due to the application of 4g4g patch.
The bug is harmless, but wastes a bit memory.

A very simple patch which removes the unused variable is joined.

Comment 1 Jerome Marchand 2007-03-30 09:34:57 UTC
Created attachment 151262 [details]
patch file

Comment 2 RHEL Product and Program Management 2007-05-22 04:04:25 UTC
This request was evaluated by Red Hat Product Management for inclusion in a Red
Hat Enterprise Linux maintenance release.  Product Management has requested
further review of this request by Red Hat Engineering, for potential
inclusion in a Red Hat Enterprise Linux Update release for currently deployed
products.  This request is not yet committed for inclusion in an Update
release.

Comment 3 Jerome Marchand 2007-06-29 09:06:42 UTC
committed in stream U6 build 55.14. A test kernel with this patch is available
from http://people.redhat.com/~jbaron/rhel4/

Comment 4 Jerome Marchand 2007-06-29 09:07:47 UTC
*** Bug 246109 has been marked as a duplicate of this bug. ***

Comment 7 errata-xmlrpc 2007-11-15 16:24:17 UTC
An advisory has been issued which should help the problem
described in this bug report. This report is therefore being
closed with a resolution of ERRATA. For more information
on the solution and/or where to find the updated files,
please follow the link below. You may reopen this bug report
if the solution does not work for you.

http://rhn.redhat.com/errata/RHBA-2007-0791.html



Note You need to log in before you can comment on or make changes to this bug.