Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 234561 - CK804 AC'97 Audio Controller disappears from the installed soundcards list upon reboot
Summary: CK804 AC'97 Audio Controller disappears from the installed soundcards list up...
Keywords:
Status: CLOSED DUPLICATE of bug 232217
Alias: None
Product: Fedora
Classification: Fedora
Component: alsa-utils
Version: rawhide
Hardware: x86_64
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Martin Stransky
QA Contact:
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2007-03-30 04:25 UTC by Sergiu Giurgiu
Modified: 2007-11-30 22:12 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2007-05-16 13:14:17 UTC


Attachments (Terms of Use)
a list of outputs from various commands (dmesg,lspci,modprobe.conf,etc.) (deleted)
2007-03-30 04:25 UTC, Sergiu Giurgiu
no flags Details
the scsconfig.log file generated by system-config-soundcard (deleted)
2007-03-30 12:15 UTC, Sergiu Giurgiu
no flags Details

Description Sergiu Giurgiu 2007-03-30 04:25:42 UTC
Description of problem:
I have 2 sound devices: Logitech USB headset and an onboard nVidia Corporation
CK804 AC'97 Audio Controller (rev a2) sound-card . Upon first boot, the Nvidia
sound card is detected fine and the sound test works (i can hear the sound
sample in my speakers). If i do not touch the default device in the Volume
control application, everything is fine upon subsequent reboots. However, if I
change the default device to the USB headset, then reboot, the Nvidia card
disappears from the list of installed sound cards. Deleting the
/etc/asound.state file, running alsactl and alsamixer commands few times (not
changing anything) and rebooting, it brings the soundcard back again. I never
found a pattern though, and I cannot see what I could have done to bring it back
, and I am unable to reproduce it consistently. 
What I am able to reproduce all the time is that if the USB device is selected
as the default device, the Nvidia soundcard disappears from the list fo
installed devices.


Version-Release number of selected component (if applicable):
Fedora 7 test3 (the same behavior appears in Fedora Core 6)

How reproducible:
Always. 

Steps to Reproduce:
1. Set the USB audio device as the default audio device in Volume Control
application
2. Reboot
3.
  
Actual results:
Nvidia soundcard disappears from the list of installed sound devices

Expected results:
To be there.

Additional info:

Comment 1 Sergiu Giurgiu 2007-03-30 04:25:43 UTC
Created attachment 151251 [details]
a list of outputs from various commands (dmesg,lspci,modprobe.conf,etc.)

Comment 2 Martin Stransky 2007-03-30 06:58:33 UTC
please run system-config-soundcard, create a log and attach it there
(/root/scsconfig.log)

Comment 3 Sergiu Giurgiu 2007-03-30 12:15:50 UTC
Created attachment 151268 [details]
the scsconfig.log file generated by system-config-soundcard

Comment 4 Sergiu Giurgiu 2007-03-30 23:56:22 UTC
I have attached the scsconfig.log file as requested

Comment 5 Matthew Miller 2007-04-10 15:53:47 UTC
Bulk message: Fedora 7 test bugs should be filed against "devel", not against
test1/2/3. This isn't obvious, I know. Moving this report so it isn't lost.

Comment 6 Martin Stransky 2007-05-16 13:14:17 UTC
yep, it's a dupe of Bug 232217

*** This bug has been marked as a duplicate of 232217 ***


Note You need to log in before you can comment on or make changes to this bug.