Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 234555 - logrotate policy of setroubleshoot-server package has bad path
Summary: logrotate policy of setroubleshoot-server package has bad path
Keywords:
Status: CLOSED DUPLICATE of bug 233760
Alias: None
Product: Fedora
Classification: Fedora
Component: setroubleshoot
Version: 6
Hardware: i386
OS: Linux
medium
medium
Target Milestone: ---
Assignee: John Dennis
QA Contact: Ben Levenson
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2007-03-30 03:02 UTC by Kenneth A. Redler
Modified: 2007-11-30 22:12 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2007-03-30 11:15:36 UTC


Attachments (Terms of Use)

Description Kenneth A. Redler 2007-03-30 03:02:25 UTC
Description of problem:
The logrotate policy included with the setroubleshoot-server-1.9.4-1.fc7 package
has a faulty path.

Version-Release number of selected component (if applicable):
setroubleshoot-server-1.9.4-1.fc7

How reproducible:
Completely

Steps to Reproduce:
1. install setroubleshoot-server-1.9.4-1.fc7
2. execute the logrotate rule for the package
3. you get error mail
  
Actual results:
The email looks like this:
Date: Thu, 29 Mar 2007 12:41:57 -0500
From: Anacron <root@jireh.yhwh.com>
To: root@jireh.yhwh.com
Subject: Anacron job for 'jireh.yhwh.com' cron.daily
/etc/cron.daily/logrotate:

error: error accessing /usr/local/var/log/setroubleshoot: No such file or
+directory
error: setroubleshoot:1 glob failed for /usr/local/var/log/setroubleshoot/*.log
error: found error in /usr/local/var/log/setroubleshoot/*.log , skipping


Expected results:
There should be no error e-mail.
The path should be /var/log/setroubleshoot not /usr/local/var/log/setroubleshoot

Additional info:

The diff is as follows:

--- /etc/logrotate.d/setroubleshoot     2007-03-29 15:50:13.000000000 -0500
+++ /etc/logrotate.d/setroubleshoot.orig        2007-03-29 16:00:19.000000000 -0500
@@ -1,4 +1,4 @@
-/var/log/setroubleshoot/*.log {
+/usr/local/var/log/setroubleshoot/*.log {
     weekly
     rotate 2
     missingok

Comment 1 Kenneth A. Redler 2007-03-30 11:15:36 UTC

*** This bug has been marked as a duplicate of 233760 ***


Note You need to log in before you can comment on or make changes to this bug.