Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 234537 - scd crashes
Summary: scd crashes
Keywords:
Status: CLOSED RAWHIDE
Alias: None
Product: Fedora
Classification: Fedora
Component: system-config-display
Version: rawhide
Hardware: All
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Adam Jackson
QA Contact:
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2007-03-29 21:05 UTC by mail@romal.de
Modified: 2018-04-11 16:04 UTC (History)
3 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2007-11-17 13:58:23 UTC


Attachments (Terms of Use)
xorg.conf wich scd does not like very much. (deleted)
2007-03-29 21:05 UTC, mail@romal.de
no flags Details

Description mail@romal.de 2007-03-29 21:05:17 UTC
Description of problem:

scd crashes while starting

Version-Release number of selected component (if applicable):

[root@helios ~]# rpm --query system-config-display
system-config-display-1.0.50-1.fc7


How reproducible:

Every time.

Steps to Reproduce:
1.
2.
3.
  
Actual results:


Expected results:


Additional info:

Crashlog:

[root@helios ~]# system-config-display 
Traceback (most recent call last):
  File "/usr/share/system-config-display/xconf.py", line 315, in <module>
    hardware_state = XF86HardwareState(xconfig)
  File "/usr/lib/python2.5/site-packages/rhpxl/xhwstate.py", line 175, in __init__
    self.init_from_xconfig(xconfig)
  File "/usr/lib/python2.5/site-packages/rhpxl/xhwstate.py", line 294, in
init_from_xconfig
    self.all_resolutions.sort (compare_resolution)
  File "/usr/lib/python2.5/site-packages/rhpxl/xhwstate.py", line 58, in
compare_resolution
    (w1, h1) = resolution_from_string(res1)
  File "/usr/lib/python2.5/site-packages/rhpxl/xhwstate.py", line 48, in
resolution_from_string
    return (tokens[0], tokens[1])
IndexError: list index out of range
[root@helios ~]#

Comment 1 mail@romal.de 2007-03-29 21:05:17 UTC
Created attachment 151238 [details]
xorg.conf wich scd does not like very much.

Comment 2 Russell Harrison 2007-05-15 20:34:54 UTC
I'm also seeing this problem on a lenovo T60p widescreen

# lspci | grep ATI
01:00.0 VGA compatible controller: ATI Technologies Inc M56GL [Mobility FireGL
V5250]

# rpm -q system-config-display
system-config-display-1.0.51-1.fc7

# system-config-display -v --reconfig
Trying with card: ATI Technologies Inc M56GL [Mobility FireGL V5250]
Traceback (most recent call last):
  File "/usr/share/system-config-display/xconf.py", line 381, in <module>
    dialog = xConfigDialog.XConfigDialog(hardware_state, xconfig,
rhpxl.videocard.VideoCardInfo())
  File "/usr/share/system-config-display/xConfigDialog.py", line 533, in __init__
    self.state.recalc_mode()
  File "/usr/lib64/python2.5/site-packages/rhpxl/xhwstate.py", line 387, in
recalc_mode
    self.colordepth = availableDepth[-1]
IndexError: list index out of range

Comment 3 Anton Keks 2007-06-09 17:51:05 UTC
And me (system-config-display-1.0.51-1.fc7):

Traceback (most recent call last):
  File "/usr/share/system-config-display/xconf.py", line 381, in <module>
    dialog = xConfigDialog.XConfigDialog(hardware_state, xconfig,
rhpxl.videocard.VideoCardInfo())
  File "/usr/share/system-config-display/xConfigDialog.py", line 533, in __init__
    self.state.recalc_mode()
  File "/usr/lib/python2.5/site-packages/rhpxl/xhwstate.py", line 387, in
recalc_mode
    self.colordepth = availableDepth[-1]
IndexError: list index out of range


Comment 4 Matěj Cepl 2007-11-02 10:01:08 UTC
Weird, I wonder why we don't have hundred duplicates for this. Could you please
check that this bug could be reproduced with the currently updated Rawhide, please?

Comment 5 mail@romal.de 2007-11-15 14:19:42 UTC
Seems to be gone. Good work :-)


Note You need to log in before you can comment on or make changes to this bug.