Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 234514 - tetex dependency
Summary: tetex dependency
Keywords:
Status: CLOSED CANTFIX
Alias: None
Product: Fedora
Classification: Fedora
Component: texmaker
Version: 6
Hardware: All
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Deji Akingunola
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2007-03-29 19:19 UTC by Kevac Marko
Modified: 2007-11-30 22:12 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2007-03-30 06:09:39 UTC


Attachments (Terms of Use)

Description Kevac Marko 2007-03-29 19:19:05 UTC
Description of problem:
texmaker depending on tetex

How reproducible:

yum install texmaker

Installing:
 texmaker                i386       1:1.5-1.fc6      extras            1.0 M
Installing for dependencies:
 nas                     i386       1.8a-2.fc6       extras            645 k
 qt4                     i386       4.2.3-3.fc6.1    extras            1.1 M
 qt4-x11                 i386       4.2.3-3.fc6.1    extras            5.4 M
 tetex                   i386       3.0-32.fc6       core               13 M
 tetex-dvipost           i386       1.1-6.fc6        extras             31 k
 tetex-dvips             i386       3.0-32.fc6       core              585 k
 tetex-fonts             i386       3.0-32.fc6       core               29 M
 tetex-latex             i386       3.0-32.fc6       core              5.4 M

Expected results:

Because i am using tex-live and because texmaker is just edito, i think he dont
need to depend on obsolete tetex.

Comment 1 Deji Akingunola 2007-03-29 19:55:13 UTC
Is tex-live already in Fedora repositories? if so, then it (tex-live package)
should properly obsolete tetex. I'm going to remove it though and just require
tetex-latex and(*-fonts and *-dvipost) 

Comment 2 Kevac Marko 2007-03-29 20:02:02 UTC
No, tex-live is not in FC6. But i think that i can choose latex distibution
myself, not the editor (just editor). Isn't than right?

Comment 3 Deji Akingunola 2007-03-30 06:09:39 UTC
Yes you're right. I've just checked again, and the dependency is on tetex-latex,
which makes sense (there's no hard dependency on tetex). Once tex-live enters
enters Fedora, the issue will resolve itself.
Thanks.


Note You need to log in before you can comment on or make changes to this bug.