Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 234503 - Copy-and-paste entire sheet gives error
Summary: Copy-and-paste entire sheet gives error
Keywords:
Status: CLOSED WONTFIX
Alias: None
Product: Fedora
Classification: Fedora
Component: openoffice.org
Version: 6
Hardware: All
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Caolan McNamara
QA Contact:
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2007-03-29 18:12 UTC by Christopher Beland
Modified: 2007-11-30 22:12 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2007-03-29 18:49:54 UTC


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
OpenOffice.org 74545 None None None Never

Description Christopher Beland 2007-03-29 18:12:36 UTC
I have two sheets which I wish to merge.  I select all cells in the first one by
clicking on the box in the upper-left-hand corner, between the row labels and
column labels.  I hit Ctrl-c.  Then I select a cell in the second sheet and hit
Ctrl-v.  I get the error: "There is not enough space on the sheet to insert here."

This does not make sense; there are only a few rows and columns in the first
sheet.  If I explicitly select the rows and columns I need (all of those that
actually have data, not including the seemingly infinite number of empty cells)
by dragging from one corner of the data to its diagonal opposite, I can
cut-and-paste without any problem.

I think this operation should just work without any questions, perhaps unless
there's a question about whether or not the "empty" cells at the fringes of the
copied should erase data in the one being pasted into.

A more helpful error message would also be an improvement.

This is with openoffice.org-calc-2.0.4-5.5.17.

Comment 1 Caolan McNamara 2007-03-29 18:49:54 UTC
See: http://qa.openoffice.org/issues/show_bug.cgi?id=74545  basically the empty
rows and columns do matter, excel does this as well. You could raise a
suggestion upstream to select only the cells with content in them when clicking
the currently "select all" top left corner button. Or some other way of handling
the paste, but for the moment this is how it works by design.

Comment 2 Christopher Beland 2007-03-29 19:21:53 UTC
Well, my point is that the behavior is not very user-friendly, whether or not it
was intentional or is just as unfriendly as other applications.

In any case, I have taken your suggestion and opened a new request at
http://qa.openoffice.org/issues/show_bug.cgi?id=75880


Note You need to log in before you can comment on or make changes to this bug.