Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 234489 - RHEL5 module-init-tools: add --no-mkinitrd option to weak-modules
Summary: RHEL5 module-init-tools: add --no-mkinitrd option to weak-modules
Keywords:
Status: CLOSED DUPLICATE of bug 229512
Alias: None
Product: Red Hat Enterprise Linux 5
Classification: Red Hat
Component: module-init-tools
Version: 5.0
Hardware: All
OS: Linux
medium
medium
Target Milestone: ---
: ---
Assignee: Jon Masters
QA Contact:
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2007-03-29 16:35 UTC by Matt Domsch
Modified: 2007-11-30 22:07 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2007-04-10 09:47:00 UTC
Target Upstream Version:


Attachments (Terms of Use)

Description Matt Domsch 2007-03-29 16:35:34 UTC
Description of problem:
/sbin/weak-modules always calls mkinitrd when it thinks the boot path modules
have changed.  Seems sane.  But in our factory, we'll use DKMS to install
several modules, and *then* at the end, will remake the initrd.  As it stands,
/sbin/weak-modules will create several initrds, and several new entries in grub,
which is somewhat confusing.

Please add an option --no-mkinitrd to /sbin/weak-modules to let DKMS avoid that
mkinitrd call.  We'll mkinitrd ourselves later.

Version-Release number of selected component (if applicable):
module-init-tools-3.3-0.pre3.1.16.el5

Comment 1 Jon Masters 2007-04-10 09:47:00 UTC

*** This bug has been marked as a duplicate of 229512 ***


Note You need to log in before you can comment on or make changes to this bug.