Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 234487 - Editing HTML crashes OO Writer
Summary: Editing HTML crashes OO Writer
Keywords:
Status: CLOSED DUPLICATE of bug 410381
Alias: None
Product: Fedora
Classification: Fedora
Component: openoffice.org
Version: 6
Hardware: i386
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Caolan McNamara
QA Contact:
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2007-03-29 16:30 UTC by M. A. MacLain
Modified: 2008-08-02 23:40 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2007-04-05 14:19:39 UTC


Attachments (Terms of Use)

Description M. A. MacLain 2007-03-29 16:30:24 UTC
Description of problem:
Editing HTML crashes OO Writer

Version-Release number of selected component (if applicable):
openoffice.org-writer.i386 1:2.0.4-5.5.17

How reproducible:
consistent

Steps to Reproduce:
1.
2.
3.
  
Actual results:


Expected results:


Additional info: 
Crash report:
(I)    x.org loaded video driver of...
(II) Loading /usr/lib/xorg/modules/drivers/radeon_drv.so
(II) Loading /usr/lib/xorg/modules/drivers/ati_drv.so
(II) Reloading /usr/lib/xorg/modules/drivers/radeon_drv.so
(III)  Desktop is: GNOME
(IV)   libgcj version is: libgcj-4.1.1-51.fc6-i386
(V)    kernel is: Linux 2.6.20-1.2933.fc6 #1 SMP Mon Mar 19 11:38:26 EDT 2007
i686 i686 i386
(VI)   OpenOffice.org core rpm version is: openoffice.org-core-2.0.4-5.5.17-i386
(VII)  depth of root window:    24 planes
(VIII) accessibility is: false
(VIV)  fedora release is: Fedora Core release 6 (Zod)
...start sestatus details ...
SELinux status:                 enabled
SELinuxfs mount:                /selinux
Current mode:                   enforcing
Mode from config file:          enforcing
Policy version:                 21
Policy from config file:        targeted
...end sestatus details ...
...start stackreport details ...
0x433f3ee8: /usr/lib/openoffice.org2.0/program/libuno_sal.so.3 + 0x22ee8
0x433f4b7b: /usr/lib/openoffice.org2.0/program/libuno_sal.so.3 + 0x23b7b
0xa02420:  + 0x420 (__kernel_sigreturn + 0x0)
0x488ed198: /usr/lib/libneon.so.25 + 0xe198 (ne_addr_destroy + 0x28)
0x488e85f3: /usr/lib/libneon.so.25 + 0x95f3 (ne_session_destroy + 0xa3)
0xa0b0c4: /usr/lib/gnome-vfs-2.0/modules/libhttp.so + 0x80c4
0x480c14e7: /lib/libglib-2.0.so.0 + 0x1e4e7
0x480c16e0: /lib/libglib-2.0.so.0 + 0x1e6e0
0xa0b26b: /usr/lib/gnome-vfs-2.0/modules/libhttp.so + 0x826b
0x480cea16: /lib/libglib-2.0.so.0 + 0x2ba16
0x480ce442: /lib/libglib-2.0.so.0 + 0x2b442 (g_main_context_dispatch + 0x182)
0x480d141f: /lib/libglib-2.0.so.0 + 0x2e41f
0x480d1985: /lib/libglib-2.0.so.0 + 0x2e985 (g_main_context_iteration + 0x65)
0xb81b91: /usr/lib/openoffice.org2.0/program/libvclplug_gtk680li.so + 0x11b91
0xc5e7c7: /usr/lib/openoffice.org2.0/program/libvclplug_gen680li.so + 0x517c7
(X11SalInstance::Yield(bool, bool) + 0x37)
0x447686b8: /usr/lib/openoffice.org2.0/program/libvcl680li.so + 0x956b8
(Application::Yield(bool) + 0x68)
0x4476878c: /usr/lib/openoffice.org2.0/program/libvcl680li.so + 0x9578c
(Application::Execute() + 0x3c)
0x46a12289: /usr/lib/openoffice.org2.0/program/libsoffice.so + 0x26289
(desktop::Desktop::Main() + 0x1779)
0x4476e25c: /usr/lib/openoffice.org2.0/program/libvcl680li.so + 0x9b25c
0x4476e365: /usr/lib/openoffice.org2.0/program/libvcl680li.so + 0x9b365
(SVMain() + 0x35)
0x46a03979: /usr/lib/openoffice.org2.0/program/libsoffice.so + 0x17979 (sal_main
+ 0x59)
0x46a03a04: /usr/lib/openoffice.org2.0/program/libsoffice.so + 0x17a04 (main + 0x44)
0x48756f2c: /lib/libc.so.6 + 0x15f2c (__libc_start_main + 0xdc)
0x80484a1: /usr/lib/openoffice.org2.0/program/swriter.bin + 0x4a1
...end stackreport details ...
...start sample ldd details ...
	linux-gate.so.1 =>  (0x00434000)
	libuno_sal.so.3 => /usr/lib/openoffice.org2.0/program/libuno_sal.so.3 (0x00110000)
	libuno_salhelpergcc3.so.3 =>
/usr/lib/openoffice.org2.0/program/libuno_salhelpergcc3.so.3 (0x006b0000)
	libstore.so.3 => /usr/lib/openoffice.org2.0/program/libstore.so.3 (0x00445000)
	libdl.so.2 => /lib/libdl.so.2 (0x00611000)
	libpthread.so.0 => /lib/libpthread.so.0 (0x00305000)
	libstlport_gcc.so => /usr/lib/openoffice.org2.0/program/libstlport_gcc.so
(0x0031c000)
	libstdc++.so.6 => /usr/lib/libstdc++.so.6 (0x0045e000)
	libm.so.6 => /lib/libm.so.6 (0x00b9b000)
	libgcc_s.so.1 => /lib/libgcc_s.so.1 (0x002d5000)
	libc.so.6 => /lib/libc.so.6 (0x006b5000)
	libcrypt.so.1 => /lib/libcrypt.so.1 (0x003ed000)
	/lib/ld-linux.so.2 (0x80000000)
...end sample ldd details ...

Comment 1 Caolan McNamara 2007-04-05 09:59:09 UTC
Is there any way to reproduce this ?

Comment 2 M. A. MacLain 2007-04-05 14:19:39 UTC
The html in question was discarded. HTML editing has since worked with no
difficulty.  It could have been caused by a mal-formed html.  Thanks for your
interest and efforts. Please discard the bug.
M. A. Mac Lain

Comment 3 Caolan McNamara 2007-12-18 13:54:56 UTC

*** This bug has been marked as a duplicate of 410381 ***


Note You need to log in before you can comment on or make changes to this bug.