Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 234475 - Black Squares instead of PNGs
Summary: Black Squares instead of PNGs
Keywords:
Status: CLOSED DUPLICATE
Alias: None
Product: Red Hat Enterprise Linux 5
Classification: Red Hat
Component: libgnomeprint22
Version: 5.0
Hardware: All
OS: Linux
medium
medium
Target Milestone: ---
: ---
Assignee: Marek Kašík
QA Contact:
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2007-03-29 15:36 UTC by James Cape
Modified: 2008-04-21 12:32 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2008-04-21 12:32:14 UTC


Attachments (Terms of Use)

Description James Cape 2007-03-29 15:36:25 UTC
Description of problem:

Printing PNGs via CUPS outputs black square where the the image would be.

Version-Release number of selected component (if applicable):

2.12.1-9.el5

How reproducible:

Every time, the TIFF version of this bug is in upstream bugzilla as well:
http://bugzilla.gnome.org/show_bug.cgi?id=355590

Steps to Reproduce:
1. Take a screenshot with gnome-screenshot
2. Open the resulting file
3. Try to print
4. Big black square on print output

Actual results:

The image is a big black square.

Expected results:

The image is output as it appears onscreen.

Additional info:

The GNOME bug mentions gamma issues, and was fixed by dropping libgnomeprint.
JPEG images work fine, but there's no obvious way to change the output format of
the screenshot. Also, a shell script which runs ( pngtopnm | pnmtops | lpr -H
cupsserv -Pprinter ) works fine.

Comment 1 Marek Kašík 2008-04-21 12:32:14 UTC
This problem is caused by wrong treating of RGBA images. They are printed as
RGBA images with 4 components. But 4 components images are automatically treated
as CMYK images by postscript.
This bug is duplicate of bug #252175, which is already fixed. I'm closing this
bug with resolution DUPLICATE.

  Thank you for reporting this bug

    Marek

P.S.: the fix of this bug will be available at Red Hat Enterprise Linux 5.2 or later

*** This bug has been marked as a duplicate of 252175 ***


Note You need to log in before you can comment on or make changes to this bug.