Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 234465 - memory test hangs repeatedly
Summary: memory test hangs repeatedly
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: Red Hat Hardware Certification Program
Classification: Red Hat
Component: Test Suite (tests)
Version: 5
Hardware: All
OS: Linux
medium
medium
Target Milestone: ---
: ---
Assignee: Greg Nichols
QA Contact: Greg Nichols
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2007-03-29 14:26 UTC by George Beshers
Modified: 2008-07-16 21:57 UTC (History)
2 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2007-05-02 17:11:37 UTC
Target Upstream Version:


Attachments (Terms of Use)

Description George Beshers 2007-03-29 14:26:56 UTC
Description of problem:
  The multithreaded memory test hangs on SkyNet (768p system).
  The problem seems to be that the termination of one or more
  threads isn't being caught.

Version-Release number of selected component (if applicable):


How reproducible:
  About 2 out of 3 times.


Steps to Reproduce:
1.  hts certify --test=memory
2.
3.
  
Actual results:
  Process hangs forever.


Expected results:


Additional info:
PV 962379
http://bugworks.engr.sgi.com/query.cgi/962379

I will add more information when I can get back onto SkyNet.

Comment 1 George Beshers 2007-04-10 19:17:53 UTC
The information available on this is limited to what can be gleened from
this weekends run.  I had observed the hang twice, but was unable to
reproduce it running a version of the test compiled with -g directly.

I suggest that a timer be added to the program, or a signal handling
routine with an external timer, to terminate the test in the case
of a suspected hang with a core dump.


Comment 2 George Beshers 2007-04-19 22:02:43 UTC
This did not happen the last time I ran the test w/ hts.
After a brief IM with Greg Nichols I believe the bug is fixed.


Note You need to log in before you can comment on or make changes to this bug.