Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 234444 - dmraid-1.0.0.rc14-1
Summary: dmraid-1.0.0.rc14-1
Keywords:
Status: CLOSED DUPLICATE
Alias: None
Product: Red Hat Enterprise Linux 4
Classification: Red Hat
Component: dmraid
Version: 4.0
Hardware: x86_64
OS: Linux
medium
medium
Target Milestone: ---
: ---
Assignee: Milan Broz
QA Contact: Corey Marthaler
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2007-03-29 11:06 UTC by David Nutter
Modified: 2013-03-01 04:05 UTC (History)
6 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2007-04-20 20:09:07 UTC


Attachments (Terms of Use)
RPM queries illustrating dependency issues (deleted)
2007-03-29 11:06 UTC, David Nutter
no flags Details

Description David Nutter 2007-03-29 11:06:14 UTC
Description of problem:

dmraid-1.0.0.rc14-1 (Beta channel) fails to install due to dependency on
'kpartx' which is provided by no package. The binary /sbin/kpartx exists in the
package device-mapper-multipath but that is already pulled in by the dependency
on libdevmapper.so.1.02. 

Version-Release number of selected component (if applicable):

dmraid-1.0.0.rc14-1_RHEL4_U5
device-mapper-multipath-0.4.5-21.RHEL4

How reproducible:

Try to install the dmraid package while subscribed to the RHEL4 beta channel.

See attached file for RPM queries illustrating the problem.

Actual results:


Expected results:


Additional info:

This was tested on an AMD64 machine but I expect the bug is readily reproducible
on all platforms as it is a packaging rather than a program code issue.

Comment 1 David Nutter 2007-03-29 11:06:14 UTC
Created attachment 151185 [details]
RPM queries illustrating dependency issues

Comment 2 Milan Broz 2007-04-20 20:09:07 UTC

*** This bug has been marked as a duplicate of 229267 ***


Note You need to log in before you can comment on or make changes to this bug.