Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 234443 - Files in /usr/lib un-owned by any package
Summary: Files in /usr/lib un-owned by any package
Keywords:
Status: CLOSED NEXTRELEASE
Alias: None
Product: Red Hat Enterprise Linux 4
Classification: Red Hat
Component: python
Version: 4.0
Hardware: All
OS: Linux
medium
low
Target Milestone: ---
: ---
Assignee: Jeremy Katz
QA Contact: Brock Organ
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2007-03-29 10:50 UTC by paul boin
Modified: 2007-11-30 22:07 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2007-03-29 14:32:55 UTC


Attachments (Terms of Use)

Description paul boin 2007-03-29 10:50:15 UTC
Description of problem:


Version-Release number of selected component (if applicable):

$rpm -qa | grep '^python'
python-devel-2.3.4-14.3
python-ldap-2.0.1-2
python-2.3.4-14.3


file /usr/lib/python2.3/site-packages/japanese/aliases/__init__.pyo is not owned
by any package
file /usr/lib/python2.3/site-packages/japanese/__init__.pyo is not owned by any
package
file /usr/lib/python2.3/site-packages/libxml2.pyc is not owned by any package
file /usr/lib/python2.3/site-packages/rhpl/gzread.pyo is not owned by any package
file /usr/lib/python2.3/site-packages/rhpl/__init__.pyo is not owned by any package
file /usr/lib/python2.3/site-packages/rhpl/translate.pyo is not owned by any package
file /usr/lib/python2.3/site-packages/xf86config.pyc is not owned by any package 


Steps to Reproduce:

"rpm -qf" on any of the above files.
  
Actual results:

RPM reports the files aren't owned by any package

Expected results:

Since these files are in /usr/lib, they should be owned by a package.

Additional info:

Comment 1 Jeremy Katz 2007-03-29 14:32:55 UTC
The files also aren't shipped by any package; they get created at runtime when
you run a python app with -O2.

With RHEL5, we've moved to always pre-generating all of the .pyc and .pyo files
which helps to avoid things like this.


Note You need to log in before you can comment on or make changes to this bug.