Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 234435 - Recompiling gcc-4.1.1-52 with firefox-*-1.5.0.10 installed fails due to missing firefox-devel xpcom include
Summary: Recompiling gcc-4.1.1-52 with firefox-*-1.5.0.10 installed fails due to missi...
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Enterprise Linux 5
Classification: Red Hat
Component: gcc
Version: 5.0
Hardware: i386
OS: Linux
medium
medium
Target Milestone: ---
: ---
Assignee: Jakub Jelinek
QA Contact:
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2007-03-29 07:14 UTC by Paul-Erik Törrönen
Modified: 2007-11-30 22:07 UTC (History)
2 users (show)

Fixed In Version: RHBA-2007-0616
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2007-11-07 20:09:06 UTC
Target Upstream Version:


Attachments (Terms of Use)
Patch to fix the missing gcj xpcom-include (deleted)
2007-03-29 07:14 UTC, Paul-Erik Törrönen
no flags Details | Diff


Links
System ID Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2007:0616 normal SHIPPED_LIVE gcc bug fix update 2007-10-30 23:07:14 UTC

Description Paul-Erik Törrönen 2007-03-29 07:14:50 UTC
Description of problem:
When recompiling the gcc-4.1.1-52, the recompile fails in the gcj-section due to
missing header files located in the /usr/include/firefox-1.5.0.10/xpcom directory

Version-Release number of selected component (if applicable):
firefox-devel-1.5.0.10-2
gcc-4.1.1-52

How reproducible:
, recompile the gcc-4.1.1-52.el5.2.src.rpm

Steps to Reproduce:
1. install firefox-1.5.0.10-2-* packages
2. recompile the gcc-4.1.1-52.el5.2.src.rpm
  
Actual results:
Recompile fails with errors of missing header files

Expected results:
The gcc packages should be recompiled succesfully

Additional info:
I've included a patch which contains modification to the
libjava/classpath/configure.ac (and configure which was created by running the
autoconfig). With this patch the recompile of gcc is completed succesfully.

Comment 1 Paul-Erik Törrönen 2007-03-29 07:14:51 UTC
Created attachment 151180 [details]
Patch to fix the missing gcj xpcom-include

Comment 2 Jakub Jelinek 2007-03-29 09:52:03 UTC
This is already fixed for some time in Fedora development gcc and will be
obviously fixed in RHEL5.1 gcc errata (without it it wouldn't build).
This is not severe enough to warrant async errata though.

Comment 3 RHEL Product and Program Management 2007-03-29 10:04:02 UTC
This request was evaluated by Red Hat Product Management for inclusion in a Red
Hat Enterprise Linux maintenance release.  Product Management has requested
further review of this request by Red Hat Engineering, for potential
inclusion in a Red Hat Enterprise Linux Update release for currently deployed
products.  This request is not yet committed for inclusion in an Update
release.

Comment 5 Jakub Jelinek 2007-06-27 08:05:35 UTC
Should be fixed,
gcc-4.1.2-13.el5 built against firefox-1.5.0.12-1.el5 just fine.

Comment 11 errata-xmlrpc 2007-11-07 20:09:06 UTC
An advisory has been issued which should help the problem
described in this bug report. This report is therefore being
closed with a resolution of ERRATA. For more information
on the solution and/or where to find the updated files,
please follow the link below. You may reopen this bug report
if the solution does not work for you.

http://rhn.redhat.com/errata/RHBA-2007-0616.html



Note You need to log in before you can comment on or make changes to this bug.