Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 234404 - Cannot manage big listboxes with perl-Tk.
Summary: Cannot manage big listboxes with perl-Tk.
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: perl
Version: rawhide
Hardware: i386
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Andreas Bierfert
QA Contact: David Lawrence
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2007-03-28 21:30 UTC by Pierre Lacaze
Modified: 2008-01-07 01:29 UTC (History)
3 users (show)

Fixed In Version: 804.028-1.fc8
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2008-01-07 01:29:20 UTC


Attachments (Terms of Use)
Perl program which crashes. (deleted)
2007-03-28 21:30 UTC, Pierre Lacaze
no flags Details

Description Pierre Lacaze 2007-03-28 21:30:06 UTC
Description of problem:
Try to execute a little perl program (in attachment), creating a listbox of 200
entries, then try to select at the same time these entries. It fails.

Version-Release number of selected component (if applicable):
Fedora 7 test 2

How reproducible:
perl bugperl.pl


Actual results:
A new listbox windows is displayed, but it disappears immediately, and the
following error is displayed:

selection conversion left too many bytes unconverted
Abandon


Expected results:
Under windows (ActiveState Perl, + TK804 library), there is no error, and the
listbox window is displayed properly. 


Additional info: see attachment. If you replace the 200 in the loop by 30, it
works well. 
If you comment the 
$lbox->selectionSet(0,'end');
line, it works well too.

Comment 1 Pierre Lacaze 2007-03-28 21:30:06 UTC
Created attachment 151170 [details]
Perl program which crashes.

Comment 2 Steven Pritchard 2007-03-29 15:21:56 UTC
Is this using perl-Tk from Extras or a locally compiled module?

Comment 3 Pierre Lacaze 2007-03-29 19:29:27 UTC
I did not compile perl-Tk myself. Here is a yum info output.

Name   : perl-Tk
Arch   : i386
Version: 804.027
Release: 10.fc6
Size   : 6.7 M
Repo   : installed
Summary: Perl Graphical User Interface ToolKit

Name   : perl
Arch   : i386
Epoch  : 4
Version: 5.8.8
Release: 15.fc7
Size   : 28 M
Repo   : installed
Summary: The Perl programming language


Comment 4 Andreas Bierfert 2007-04-01 07:39:20 UTC
Hm I suspect that perl-Tk should be rebuild because on FC6 it works without a
problem. Will push a rebuild now. Please get back to me if it works afterwards.

Comment 5 Pierre Lacaze 2007-04-02 18:40:06 UTC
Hello,

I do not know if you have pushed the rebuild (yum update perl-Tk gives nothing
new). But I downloaded the sources from the Debian site
http://packages.debian.org/stable/source/perl-tk (file perl-tk_800.025.orig),
compiled them, and the bug has disappeared. 



Comment 6 Pierre Lacaze 2007-04-04 19:00:21 UTC
Hello,

I unsinstalled my self-compiled package, and installed perl-Tk via yum instead.
Now, the release is 804.027-11.fc7.

On my computer, the bug happens again, just like before. In fact, I think the
bug already happened in FC6, so I suppose a rebuild is not enough to solve the
bug. We should use the latest sources. 



Comment 7 Fedora Update System 2008-01-03 01:34:55 UTC
perl-Tk-804.028-1.fc8 has been pushed to the Fedora 8 testing repository.  If problems still persist, please make note of it in this bug report.
 If you want to test the update, you can install it with 
 su -c 'yum --enablerepo=updates-testing update perl-Tk'

Comment 8 Fedora Update System 2008-01-03 01:35:55 UTC
perl-Tk-804.028-1.fc7 has been pushed to the Fedora 7 testing repository.  If problems still persist, please make note of it in this bug report.
 If you want to test the update, you can install it with 
 su -c 'yum --enablerepo=updates-testing update perl-Tk'

Comment 9 Pierre Lacaze 2008-01-03 20:35:35 UTC
Hi,

I donwloaded the package for Fedora 7. My perl programs work much better now.
Thank you! You can close the bug.



Comment 10 Andreas Bierfert 2008-01-03 22:47:15 UTC
Thanks for the response. Bug will be closed once the package goes live.

Comment 11 Fedora Update System 2008-01-07 01:17:58 UTC
perl-Tk-804.028-1.fc7 has been pushed to the Fedora 7 stable repository.  If problems still persist, please make note of it in this bug report.

Comment 12 Fedora Update System 2008-01-07 01:29:16 UTC
perl-Tk-804.028-1.fc8 has been pushed to the Fedora 8 stable repository.  If problems still persist, please make note of it in this bug report.


Note You need to log in before you can comment on or make changes to this bug.