Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 234386 - Curly braces placed in passwords changed via RHN prevent users from logging in.
Summary: Curly braces placed in passwords changed via RHN prevent users from logging in.
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: Red Hat Satellite 5
Classification: Red Hat
Component: Usability
Version: unspecified
Hardware: All
OS: Linux
medium
medium
Target Milestone: ---
Assignee: John Sanda
QA Contact: Mark Sechrest
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2007-03-28 20:17 UTC by Alex Wood
Modified: 2007-10-24 02:46 UTC (History)
2 users (show)

Fixed In Version: 5.0.3
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2007-10-02 16:37:46 UTC


Attachments (Terms of Use)

Description Alex Wood 2007-03-28 20:17:24 UTC
Steps to Reproduce:
1.  Find a user with RHN entitlements.
2.  Login as that user via /wapps/sso/rhn/login.html
3.  Go to https://rhn.webqa.redhat.com/rhn/account/UserDetails.do
4.  Change the user's password to something containing a curly brace, e.g.
"pass{word".
5.  Log out.
6.  Attempt to log back in.
  
Actual results:  The password is not accepted.

In UGC, however, changing the password to one with a curly brace actually does work.

Comment 1 Mark Sechrest 2007-04-05 20:38:20 UTC
Let's check to be sure our LDAP interface is properly encoding. Maybe updating
via triggers is taking a different path?

Comment 2 Grant Shipley 2007-04-11 18:39:26 UTC
This is a RHN bug.  RHN seems to be stripping off characters without telling the
user.

Example:
https://rhn.webqa.redhat.com/rhn/account/UserDetails.do
change password to
{{{test123{}
test123 gets sent.

Also, if you change it to
{{{test123
with a confirmation of
test123 
it will match.



Comment 3 Grant Shipley 2007-09-07 14:45:43 UTC
SSO error message states:
Password must be ASCII and cannot contain the following special                
   characters (") (<) (>) (space)




Comment 4 John Sanda 2007-09-07 19:45:58 UTC
Checked in revision 117674. Disabled the logic that scrubs the password field.
Added logic to check the password for illegal characters.

Comment 5 John Sanda 2007-09-13 12:09:50 UTC
Test Plan:

Update your password
1. Log into RHN and go to https://rhn.webqa.redhat.com/rhn/account/UserDetails.do.
2. Update your password to include one or more of the characters (delimited by
parens) in Comment 3.
3. Verify that you are sent back UserDetails.do and an error message is
displayed that says the characters from Comment 3 are illegal.
4. Enter a new password without any illegal characters but includes a curly brace.
5. Submit the form, logout and verify that you can log back in.

Extensions:
1.a Update another user's password
1.  Go to https://rhn.webqa.redhat.com/rhn/users/ActiveList.do.
2. Select a user other than yourself.
3. Repeat steps 2 through 5 from above.

Comment 6 Mike Orazi 2007-09-18 12:00:59 UTC
Mark,

Please verify on your end, but RHN seems to be stopping users from entering
",<,> and the space character


Note You need to log in before you can comment on or make changes to this bug.