Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 234352 - iser bug fixes for 5.1
Summary: iser bug fixes for 5.1
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Enterprise Linux 5
Classification: Red Hat
Component: kernel
Version: 5.0
Hardware: All
OS: Linux
medium
medium
Target Milestone: ---
: ---
Assignee: Mike Christie
QA Contact: Martin Jenner
URL:
Whiteboard:
: 227701 240146 (view as bug list)
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2007-03-28 17:31 UTC by Mike Christie
Modified: 2010-03-14 21:30 UTC (History)
4 users (show)

Fixed In Version: RHBA-2007-0959
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2007-11-07 19:45:37 UTC


Attachments (Terms of Use)
rhel5 iser update (deleted)
2007-05-03 19:50 UTC, Mike Christie
no flags Details


Links
System ID Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2007:0959 normal SHIPPED_LIVE Updated kernel packages for Red Hat Enterprise Linux 5 Update 1 2007-11-08 00:47:37 UTC

Description Mike Christie 2007-03-28 17:31:47 UTC
Description of problem:

Fix bugs found in RHEL 5.0 iser release.


Version-Release number of selected component (if applicable):


How reproducible:


Steps to Reproduce:
1.
2.
3.
  
Actual results:


Expected results:


Additional info:

Comment 1 Mike Christie 2007-03-28 17:33:19 UTC
This will bring in fixes that were found in RHEL 5.0 or upstream. Patches are
upstream or on their way, and will be tested by Voltaire.

Comment 2 RHEL Product and Program Management 2007-03-28 17:45:51 UTC
This request was evaluated by Red Hat Product Management for inclusion in a Red
Hat Enterprise Linux maintenance release.  Product Management has requested
further review of this request by Red Hat Engineering, for potential
inclusion in a Red Hat Enterprise Linux Update release for currently deployed
products.  This request is not yet committed for inclusion in an Update
release.

Comment 3 Jay Turner 2007-05-03 19:38:00 UTC
Withholding QE ack as there's really no detail here about what bugs are fixed,
nor the corresponding patches.

Comment 4 Mike Christie 2007-05-03 19:50:22 UTC
Created attachment 154068 [details]
rhel5 iser update

This is rebase of the iser driver to what is upstream. Here are the git
commits:
 777a71dd4d901f055967ddbd038d2a74ffce0eb8
 8072ec2f8f6790df91e85d833e672c9c30a7ab3c
 8dfa0876d3dde5f9c1818a4c35caaabc3ddba78b
 e981f1d4b8288072ba7cf6b7141cd4aefb404383
 d81110285f7f6c07a0ce8f99a5ff158a647cd649
 5755d6dad95808a24a65dd9e61e23c305f9b077c
 87e8df7a273c7c1acb864c90b5253609c44375a6
 74a2078061409e027ccb51a28cf6174c31ab8f99
 fd6a79a786b84510d00ee6aa6449a468e6d75dee
 2e7a7426282bfa2d7dff6eddc5485af8c79a68f3
 dee234f48aa6b5ee6041d33c4fd59d2f1176e9a1
 f0938401f2252bf39615c0815734650eab9053c8
 3104a2175dc04b7a597acea90f19b033abcfc7d8
 1d426d6418d1914b592c9c307c02e488d9182fa8

The fix bugs like logout hangs when doing shutdown, fix abort taks handling,
etc.

I do not have the hardware so I trust the iser guys to test the update they
sent. I reviewed the patches when they came through the open-iscsi list and
linux-iscsi list.

Comment 6 Mike Christie 2007-05-21 15:55:52 UTC
*** Bug 240146 has been marked as a duplicate of this bug. ***

Comment 7 Mike Christie 2007-06-01 02:11:00 UTC
*** Bug 227701 has been marked as a duplicate of this bug. ***

Comment 8 Don Zickus 2007-06-16 00:37:42 UTC
in 2.6.18-27.el5
You can download this test kernel from http://people.redhat.com/dzickus/el5

Comment 12 errata-xmlrpc 2007-11-07 19:45:37 UTC
An advisory has been issued which should help the problem
described in this bug report. This report is therefore being
closed with a resolution of ERRATA. For more information
on the solution and/or where to find the updated files,
please follow the link below. You may reopen this bug report
if the solution does not work for you.

http://rhn.redhat.com/errata/RHBA-2007-0959.html



Note You need to log in before you can comment on or make changes to this bug.