Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 234315 - saving attachments doesn't work properly
Summary: saving attachments doesn't work properly
Keywords:
Status: CLOSED RAWHIDE
Alias: None
Product: Fedora
Classification: Fedora
Component: evolution
Version: rawhide
Hardware: All
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Matthew Barnes
QA Contact:
URL:
Whiteboard:
Depends On:
Blocks: FC7Target
TreeView+ depends on / blocked
 
Reported: 2007-03-28 13:38 UTC by Jonathan Kamens
Modified: 2007-11-30 22:12 UTC (History)
0 users

Fixed In Version: evolution-2.10.1-4.fc7
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2007-04-14 23:08:04 UTC


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
GNOME Bugzilla 423766 None None None Never

Description Jonathan Kamens 2007-03-28 13:38:49 UTC
I have an email message (in an Exchange folder, although I don't know if that
makes a difference) with an attachment called zones.tar.  I click "Save" and it
pops up a dialog.  In the "Location" field, I enter "/tmp/zones.tar" and hit
Enter.  Instead of creating the file /tmp/zones.tar, it creates an empty
directory called /tmp/zones.tar and doesn't save the attachment.

Next, I try simply popping up the save dialog and clicking the "Save" button,
which presumably should save the file in my home directory since that's what's
selected in the Places list if I don't change anything.  It does in fact save
the file in my home directory, but the dialog remains popped up instead of
dismissing.

I'm using evolution-2.10.0-2.fc7.

Comment 1 Matthew Barnes 2007-03-28 15:06:26 UTC
Confirming.  Looks like a regression from Evolution 2.8.

Forwarding the bug upstream [1], but leaving it open here so we can track it for
Fedora 7.

[1] http://bugzilla.gnome.org/show_bug.cgi?id=423766

Comment 2 Matthew Barnes 2007-04-14 23:08:04 UTC
Fixed the reproducible parts in evolution-2.10.1-4.fc7.

See the upstream bug for details on the unreproducible parts.


Note You need to log in before you can comment on or make changes to this bug.