Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 234314 - "mirroring with logging" with three disks, it seems not to possible to define which disk gets which part.
Summary: "mirroring with logging" with three disks, it seems not to possible to define...
Keywords:
Status: CLOSED DUPLICATE of bug 199580
Alias: None
Product: Red Hat Cluster Suite
Classification: Retired
Component: lvm2-cluster
Version: 4
Hardware: x86_64
OS: Linux
medium
medium
Target Milestone: ---
Assignee: LVM and device-mapper development team
QA Contact: Cluster QE
URL:
Whiteboard:
Depends On:
Blocks: CMirrorBetaTracker
TreeView+ depends on / blocked
 
Reported: 2007-03-28 13:36 UTC by Frank Weyns
Modified: 2013-11-18 01:03 UTC (History)
8 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2007-07-27 16:08:56 UTC


Attachments (Terms of Use)

Description Frank Weyns 2007-03-28 13:36:10 UTC
Description of problem: RHEL 4.5 Beta hostbased mirroring

When using "mirroring with logging" with three disks, it seems not to possible
to define which disk gets which part. (RHEL 5 doc state it should work)

example:
Disk dm-11 is a disk on location CCAZ
disks dm5 en dm-6 are disks on location CCAN

De configuration mqu_QTTEST is not Ok because mimage0 and 1 are both on
the same location ...

[root@bsxe01001 ~]# lvs -a -o +devices
  LV                      VG     Attr   LSize   Origin Snap%  Move Log
Copy%  Devices
  log_QTTEST              vgmqm  mwi-a- 300.00M
log_QTTEST_mlog     0.00 log_QTTEST_mimage_0(0),log_QTTEST_mimage_1(0)
  [log_QTTEST_mimage_0]   vgmqm  iwi---
300.00M                                             /dev/dm-11(1)
  [log_QTTEST_mimage_1]   vgmqm  iwi---
300.00M                                             /dev/dm-5(50)
  [log_QTTEST_mlog]       vgmqm  lwi---
4.00M                                             /dev/dm-6(50)
  mqu_QTTEST              vgmqm  mwi-a- 200.00M
mqu_QTTEST_mlog     0.00 mqu_QTTEST_mimage_0(0),mqu_QTTEST_mimage_1(0)
  [mqu_QTTEST_mimage_0]   vgmqm  iwi---
200.00M                                             /dev/dm-5(0)
  [mqu_QTTEST_mimage_1]   vgmqm  iwi---
200.00M                                             /dev/dm-6(0)
  [mqu_QTTEST_mlog]       vgmqm  lwi---
4.00M                                             /dev/dm-11(0)
  qmgrs_QTTEST            vgmqm  mwi-a- 300.00M
qmgrs_QTTEST_mlog   0.00
qmgrs_QTTEST_mimage_0(0),qmgrs_QTTEST_mimage_1(0)
  [qmgrs_QTTEST_mimage_0] vgmqm  iwi---
300.00M                                             /dev/dm-6(51)
  [qmgrs_QTTEST_mimage_1] vgmqm  iwi---
300.00M                                             /dev/dm-11(76)
  [qmgrs_QTTEST_mlog]     vgmqm  lwi---
4.00M                                             /dev/dm-5(125)

Hardware used:
SUN V40z with RHEL4 Update 5 beta

kernel-smp-2.6.9-50.EL

cman-kernel-smp-2.6.9-49.2
cman-kernheaders-2.6.9-49.2
cman-1.0.17-0

dlm-1.0.1-2
dlm-kernel-smp-2.6.9-46.14
dlm-kernheaders-2.6.9-46.14

GFS-kernheaders-2.6.9-71.0
GFS-6.1.13-0
GFS-kernel-smp-2.6.9-71.0

ccs-1.0.10-0

cmirror-kernel-smp-2.6.9-25.0
cmirror-1.0.1-1

lvm2-2.02.21-4.el4
lvm2-cluster-2.02.21-3.el4

Comment 1 Corey Marthaler 2007-03-28 15:28:40 UTC
This is a dup of bz 199580. There a work around given in comment #7 of that bug,
but I agree, this needs to be made even easier then that.

Comment 2 Jonathan Earl Brassow 2007-07-27 16:08:56 UTC
Additionally, the lvm manual addresses this.

Closing as dup.

*** This bug has been marked as a duplicate of 199580 ***


Note You need to log in before you can comment on or make changes to this bug.