Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 234311 - faillog / pam_faillog doesn't show all the informations faillog.h
Summary: faillog / pam_faillog doesn't show all the informations faillog.h
Keywords:
Status: CLOSED DUPLICATE
Alias: None
Product: Red Hat Enterprise Linux 4
Classification: Red Hat
Component: pam
Version: 4.4
Hardware: All
OS: Linux
medium
medium
Target Milestone: ---
: ---
Assignee: Tomas Mraz
QA Contact:
URL:
Whiteboard:
Depends On: 234308 234310
Blocks:
TreeView+ depends on / blocked
 
Reported: 2007-03-28 13:23 UTC by Jose Plans
Modified: 2007-11-17 01:14 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2007-03-28 13:41:17 UTC


Attachments (Terms of Use)
pam-faillog_short_fail_line.patch (deleted)
2007-03-28 13:27 UTC, Jose Plans
no flags Details | Diff
shadow-faillog_short_fail_line.patch (deleted)
2007-03-28 13:28 UTC, Jose Plans
no flags Details | Diff

Description Jose Plans 2007-03-28 13:23:36 UTC
Description of problem:

Bug with two dependancies: 
    * pam: [234308]
    * shadow-utils: [234310]

When using faillog, the IP or hostname information gets truncated with strncpy()
on the 12 first characters due to the sizeof() from its definition.

Used the 52 present in rawhide. This is just part of the problem on write, read
(shadow-utils) need change as well for faillog to read it, since both have the
same header I'm sending a parallel bug blocker of this one against shadow-utils.

Version-Release number of selected component (if applicable):
pam-0.77-66.14
shadow-utils-4.0.3-60.RHEL4

How reproducible:
Always

Steps to Reproduce:
1. Setup a pam stack to use pam_tally.so
2. Fail an authentication
3. Check with faillog
  
Actual results:
fail line truncated.

Expected results:
At least the IP address.

Additional info:
patch from rawhide.

Comment 1 Jose Plans 2007-03-28 13:27:02 UTC
Created attachment 151119 [details]
pam-faillog_short_fail_line.patch

Comment 2 Jose Plans 2007-03-28 13:28:06 UTC
Created attachment 151120 [details]
shadow-faillog_short_fail_line.patch

Comment 4 Tomas Mraz 2007-03-28 13:41:17 UTC
This cannot be changed due to breaking compatibility with existing faillog files.

The correct way is to backport pam_tally2.so from RHEL5.


*** This bug has been marked as a duplicate of 228044 ***


Note You need to log in before you can comment on or make changes to this bug.