Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 234310 - faillog doesn't show all the informations faillog.h
Summary: faillog doesn't show all the informations faillog.h
Keywords:
Status: CLOSED WONTFIX
Alias: None
Product: Red Hat Enterprise Linux 4
Classification: Red Hat
Component: shadow-utils
Version: 4.4
Hardware: All
OS: Linux
medium
medium
Target Milestone: ---
: ---
Assignee: Peter Vrabec
QA Contact: David Lawrence
URL:
Whiteboard:
Depends On:
Blocks: 234311
TreeView+ depends on / blocked
 
Reported: 2007-03-28 13:21 UTC by Jose Plans
Modified: 2007-11-17 01:14 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2007-04-02 09:45:47 UTC


Attachments (Terms of Use)
shadow-faillog_short_fail_line.patch (deleted)
2007-03-28 13:21 UTC, Jose Plans
no flags Details | Diff

Description Jose Plans 2007-03-28 13:21:05 UTC
Description of problem:

When using faillog, the IP or hostname information gets truncated with strncpy()
on the 12 first characters due to the sizeof() from its definition.

Used the 52 present in rawhide. This is just part of the problem on write, read
(shadow-utils) need change as well for faillog to read it, since both have the
same header I'm sending a parallel bug blocker of this one against shadow-utils.

Version-Release number of selected component (if applicable):
shadow-utils-4.0.3-60.RHEL4

How reproducible:
Always

Steps to Reproduce:
1. Setup a pam stack to use pam_tally.so
2. Fail an authentication
3. Check with faillog
  
Actual results:
fail line truncated.

Expected results:
At least the IP address.

Additional info:
patch from rawhide.

Comment 1 Jose Plans 2007-03-28 13:21:05 UTC
Created attachment 151118 [details]
shadow-faillog_short_fail_line.patch

Comment 2 Peter Vrabec 2007-04-02 09:45:47 UTC
see #234311 comment #4


Note You need to log in before you can comment on or make changes to this bug.