Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 234306 - Anaconda not in GUI even X server is able to autoconfigure itself
Summary: Anaconda not in GUI even X server is able to autoconfigure itself
Keywords:
Status: CLOSED WONTFIX
Alias: None
Product: Red Hat Enterprise Linux 5
Classification: Red Hat
Component: xorg-x11-drv-i810
Version: 5.0
Hardware: All
OS: Linux
medium
medium
Target Milestone: ---
: ---
Assignee: Adam Jackson
QA Contact:
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2007-03-28 12:20 UTC by Milan Kerslager
Modified: 2014-06-09 16:30 UTC (History)
2 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2014-06-02 13:17:44 UTC
Target Upstream Version:


Attachments (Terms of Use)
X server log (without config file, with '-depth 16' option) (deleted)
2007-03-28 12:20 UTC, Milan Kerslager
no flags Details
X server log (without config file, without '-depth 16' option) -> does not start (deleted)
2007-03-28 12:23 UTC, Milan Kerslager
no flags Details
Working xorg.conf (deleted)
2007-03-28 12:28 UTC, Milan Kerslager
no flags Details

Description Milan Kerslager 2007-03-28 12:20:32 UTC
Graphical installation does not start and text mode is used even the system is
able to work in GUI.

The system has onboar Intel 82815 graphics chip. I had to specify '-depth 16' to
the X server to be able to start without configuration file (error message was
'driver is unable to work in 32 bit depth') so this seems like default builtin
configuration file miss this color depth directive because the X server.

Comment 1 Milan Kerslager 2007-03-28 12:20:33 UTC
Created attachment 151112 [details]
X server log (without config file, with '-depth 16' option)

Comment 2 Milan Kerslager 2007-03-28 12:23:02 UTC
Created attachment 151113 [details]
X server log (without config file, without '-depth 16' option) -> does not start

Comment 3 Milan Kerslager 2007-03-28 12:28:23 UTC
Created attachment 151114 [details]
Working xorg.conf

The default color depth in the built-in config file should be 24 as the driver
is able to work in 24 bit depth but not in 32 bit depth (32 bit is the current
default).

Comment 4 Matěj Cepl 2007-03-30 15:22:02 UTC
Hi, Milan, did you change your job to QA of our X-drivers ;-)?

Comment 5 Milan Kerslager 2007-04-02 06:34:05 UTC
:-) Just trying to get useful desktop at home and at work/school... :-)
Thank you for you attention/fixing!

Comment 6 RHEL Product and Program Management 2014-03-07 13:43:09 UTC
This bug/component is not included in scope for RHEL-5.11.0 which is the last RHEL5 minor release. This Bugzilla will soon be CLOSED as WONTFIX (at the end of RHEL5.11 development phase (Apr 22, 2014)). Please contact your account manager or support representative in case you need to escalate this bug.

Comment 7 RHEL Product and Program Management 2014-06-02 13:17:44 UTC
Thank you for submitting this request for inclusion in Red Hat Enterprise Linux 5. We've carefully evaluated the request, but are unable to include it in RHEL5 stream. If the issue is critical for your business, please provide additional business justification through the appropriate support channels (https://access.redhat.com/site/support).


Note You need to log in before you can comment on or make changes to this bug.