Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 234303 - src.rpm does't build
Summary: src.rpm does't build
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Enterprise Linux 5
Classification: Red Hat
Component: util-linux
Version: 5.0
Hardware: All
OS: Linux
medium
medium
Target Milestone: ---
: ---
Assignee: Karel Zak
QA Contact: Ben Levenson
URL:
Whiteboard:
: 277761 (view as bug list)
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2007-03-28 11:35 UTC by Zenon Panoussis
Modified: 2007-11-30 22:07 UTC (History)
1 user (show)

Fixed In Version: RHBA-2007-0561
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2007-11-07 16:37:15 UTC


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2007:0561 normal SHIPPED_LIVE util-linux bug fix update 2007-10-30 15:11:47 UTC

Description Zenon Panoussis 2007-03-28 11:35:06 UTC
Description of problem:
Attempting to build the source rpm ends abruptly with 
[...]
Patch #256 (util-linux-2.13-raw-raw0.patch):
+ patch -p1 -s
1 out of 2 hunks FAILED -- saving rejects to file diskutils/raw.c.rej
error: Bad exit status (etc)

Version-Release number of selected component (if applicable):
2.13-0.44.el5

How reproducible:
Every time, obviously. 

Additional info:
Building on ppc32. I can't imagine it makes any difference, but neither can I
explain how you managed to compile it and QA it and release it, unless you used
The Force...

Related to non-public #216712.

Comment 1 Karel Zak 2007-03-28 12:51:16 UTC
Sorry for this nasty bug. There is missing "if" condition:

  %if %{include_raw}
  %patch256 -p1
  %endif

You need to recompile the package by:

  # rpmbuild --define "dist .el5" --define "rhel 5" -ba util-linux.spec

(all RHEL5 packages are compiled with these options, fortunately there is small
number of packages with with an "if 0%{dist}")

Comment 2 Zenon Panoussis 2007-03-31 14:07:57 UTC
Thanks. I can confirm it works.

Comment 3 RHEL Product and Program Management 2007-06-05 20:33:23 UTC
This request was evaluated by Red Hat Product Management for
inclusion in a Red Hat Enterprise Linux release.  Since this
bugzilla is in a component that is not approved for the current
release, it has been closed with resolution deferred.  You may
reopen this bugzilla for consideration in the next release.

Comment 10 Karel Zak 2007-09-18 08:05:24 UTC
*** Bug 277761 has been marked as a duplicate of this bug. ***

Comment 11 errata-xmlrpc 2007-11-07 16:37:15 UTC
An advisory has been issued which should help the problem
described in this bug report. This report is therefore being
closed with a resolution of ERRATA. For more information
on the solution and/or where to find the updated files,
please follow the link below. You may reopen this bug report
if the solution does not work for you.

http://rhn.redhat.com/errata/RHBA-2007-0561.html



Note You need to log in before you can comment on or make changes to this bug.